Camaleon CMS vulnerable to stored XSS through user file upload (GHSL-2024-184)
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (camaleon_cms 2.8.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems camaleon_cms
- Affected
- >= 2.8.0, < 2.8.2
- Fixed in
- 2.8.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-75j2-9gmc-m855 lists affected ranges: RubyGems camaleon_cms >=2.8.0 <2.8.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 4.8 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
A stored cross-site scripting has been found in the image upload functionality that can be used by normal registered users: It is possible to upload a SVG image containing JavaScript and it's also possible to upload a HTML document when the format parameter is manually changed to [documents][1] or a string of an [unsupported format][2]. If an authenticated user or administrator visits that uploaded image or document malicious JavaScript can be executed on their behalf (e.g. changing or deleting content inside of the CMS.) [1]: https://github.com/owen2345/camaleon-cms/blob/feccb96e542319ed608acd3a16fa5d92f13ede67/app/uploaders/camaleoncmsuploader.rb#L105-L106 [2]: https://github.com/owen2345/camaleon-cms/blob/feccb96e542319ed608acd3a16fa5d92f13ede67/app/uploaders/camaleoncmsuploader.rb#L110-L111 Impact This issue may lead to account takeover due to reflected Cross-site scripting (XSS). Remediation Only allow the upload of safe files such as PNG, TXT and others or serve all "unsafe"…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-75j2-9gmc-m855
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-75j2-9gmc-m855 Advisory: Camaleon CMS vulnerable to stored XSS through user file upload (GHSL-2024-184) IDs: GHSA-75j2-9gmc-m855 Record: https://patchnext.com/advisories/ghsa-75j2-9gmc-m855 (revision 1, source checked 26 Oct 2026, 15:48 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: camaleon_cms 2.8.2. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems camaleon_cms: affected >= 2.8.0, < 2.8.2; fixed in 2.8.2 ## Suggested inspection (read-only) - RubyGems camaleon_cms: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on camaleon_cms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-75j2-9gmc-m855 (GitHub-reviewed advisory GHSA-75j2-9gmc-m855 lists affected ranges: RubyGems camaleon_cms >=2.8.0 <2.8.2) Commands are suggestions: review each one before running it.
Loading voting…