Skip to content

← Actionable
High, CVSS 8.2amended

n8n-mcp has unauthenticated session termination and information disclosure in HTTP transport

GHSA-75hx-xj24-mqrw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (n8n-mcp 2.47.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm n8n-mcp

    Affected
    <= 2.47.5
    Fixed in
    2.47.6

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.2 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:H
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary Several HTTP transport endpoints in n8n-mcp lacked proper authentication, and the health check endpoint exposed sensitive operational metadata without credentials. Impact An unauthenticated attacker with network access to the n8n-mcp HTTP server could disrupt active MCP sessions and gather information useful for further attacks. Patches Fixed in v2.47.6. All MCP session endpoints now require Bearer authentication. The health check endpoint has been reduced to a minimal liveness response. Workarounds If you cannot upgrade immediately: - Restrict network access to the HTTP server using firewall rules, reverse proxy IP allowlists, or a VPN so that only trusted clients can reach it. - Use stdio mode (MCPMODE=stdio) instead of HTTP mode. The stdio transport does not expose any HTTP endpoints and is unaffected by this vulnerability. Upgrading to v2.47.6 is still strongly recommended. Credit Reported by @yotampe-pluto.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-75hx-xj24-mqrw

  2. Revision 1 · created ·

    Published from osv record GHSA-75hx-xj24-mqrw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-75hx-xj24-mqrw

Advisory: n8n-mcp has unauthenticated session termination and information disclosure in HTTP transport
IDs: GHSA-75hx-xj24-mqrw
Record: https://patchnext.com/advisories/ghsa-75hx-xj24-mqrw (revision 2, source checked 26 Oct 2026, 12:48 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: n8n-mcp 2.47.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm n8n-mcp: affected <= 2.47.5; fixed in 2.47.6

## Suggested inspection (read-only)
- `npm ls n8n-mcp --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on n8n-mcp.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-75hx-xj24-mqrw (OSV record GHSA-75hx-xj24-mqrw lists affected ranges: npm n8n-mcp >=0 <2.47.6 (fixed))
- Verified: https://github.com/advisories/GHSA-75hx-xj24-mqrw (GitHub-reviewed advisory GHSA-75hx-xj24-mqrw lists affected ranges: npm n8n-mcp >=0 <=2.47.5)

Commands are suggestions: review each one before running it.

Loading voting…