Skip to content

← Actionable
High, CVSS 8.7

rPGP vulnerable to parser crash on crafted RSA secret key packets through CVE-2026-21895

GHSA-7587-4wv6-m68m

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pgp 0.19.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io pgp

    Affected
    >= 0.16.0-alpha.0, < 0.19.0
    Fixed in
    0.19.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary It was possible to trigger an unhandled edge case in the Rust Crypto rsa crate through rPGP packet parsing functionality, and crash the process that runs rPGP. This problem has been patched in a new rsa version. The new release of rPGP ensures a patched version of the rsa crate is in use, which prevents this issue. Details While parsing a special RSA secret key packet, rPGP calls the rsa crate with the provided key. On vulnerable versions, this results in a Rust "panic" during key construction. Note that an attacker can trigger this situation even in places where applications don't expect to handle foreign key material, for example while attempting to receive a message. For more information on the rsa crate vulnerability, see https://github.com/RustCrypto/RSA/security/advisories/GHSA-9c48-w39g-hm26 and https://github.com/RustCrypto/RSA/pull/624. In rPGP, this has been fixed via https://github.com/rpgp/rpgp/pull/698. Impact This issue impacts availability (i.e. applications…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-7587-4wv6-m68m

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-7587-4wv6-m68m

Advisory: rPGP vulnerable to parser crash on crafted RSA secret key packets through CVE-2026-21895
IDs: GHSA-7587-4wv6-m68m
Record: https://patchnext.com/advisories/ghsa-7587-4wv6-m68m (revision 1, source checked 26 Oct 2026, 15:39 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pgp 0.19.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io pgp: affected >= 0.16.0-alpha.0, < 0.19.0; fixed in 0.19.0

## Suggested inspection (read-only)
- crates.io pgp: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pgp.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-7587-4wv6-m68m (GitHub-reviewed advisory GHSA-7587-4wv6-m68m lists affected ranges: crates.io pgp >=0.16.0-alpha.0 <0.19.0)

Commands are suggestions: review each one before running it.

Loading voting…