zerovec-derive incorrectly uses #[repr(packed)]
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (zerovec-derive 0.10.3, 0.9.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io zerovec-derive
- Affected
- < 0.9.7>= 0.10.0, < 0.10.3
- Fixed in
- 0.10.3, 0.9.7
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-74r5-g7vc-j2v2 lists affected ranges: crates.io zerovec-derive >=0 =0.10.0 <0.10.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
The affected versions make unsafe memory accesses under the assumption that #[repr(packed)] has a guaranteed field order. The Rust specification does not guarantee this, and https://github.com/rust-lang/rust/pull/125360 (1.80.0-beta) starts reordering fields of #[repr(packed)] structs, leading to illegal memory accesses. The patched versions 0.9.7 and 0.10.3 use #[repr(C, packed)], which guarantees field order.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-74r5-g7vc-j2v2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-74r5-g7vc-j2v2 Advisory: zerovec-derive incorrectly uses `#[repr(packed)]` IDs: GHSA-74r5-g7vc-j2v2 Record: https://patchnext.com/advisories/ghsa-74r5-g7vc-j2v2 (revision 1, source checked 26 Oct 2026, 15:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: zerovec-derive 0.10.3, 0.9.7. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io zerovec-derive: affected < 0.9.7; >= 0.10.0, < 0.10.3; fixed in 0.10.3, 0.9.7 ## Suggested inspection (read-only) - crates.io zerovec-derive: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on zerovec-derive. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-74r5-g7vc-j2v2 (GitHub-reviewed advisory GHSA-74r5-g7vc-j2v2 lists affected ranges: crates.io zerovec-derive >=0 =0.10.0 <0.10.3) Commands are suggestions: review each one before running it.
Loading voting…