Kubernetes apimachinery packages vulnerable to unbounded recursion in JSON or YAML parsing
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (k8s.io/apimachinery 0.0.0-20190927203648-9ce6eca90e73), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 0.0.0-20190927203648-9ce6eca90e73
- Fixed in
- 0.0.0-20190927203648-9ce6eca90e73
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-74fp-r6jw-h4mp lists affected ranges: Go k8s.io/apimachinery >=0 <0.0.0-20190927203648-9ce6eca90e73
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
CVE-2019-11253 is a denial of service vulnerability in the kube-apiserver, allowing authorized users sending malicious YAML or JSON payloads to cause kube-apiserver to consume excessive CPU or memory, potentially crashing and becoming unavailable. When creating a ConfigMap object which has recursive references contained in it, excessive CPU usage can occur. This appears to be an instance of a "Billion Laughs" attack which is quite well known as an XML parsing issue. Applying this manifest to a cluster causes the client to hang for some time with considerable CPU usage. Specific Go Packages Affected - k8s.io/apimachinery/pkg/runtime/serializer/json - k8s.io/apimachinery/pkg/util/json
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-74fp-r6jw-h4mp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-74fp-r6jw-h4mp Advisory: Kubernetes apimachinery packages vulnerable to unbounded recursion in JSON or YAML parsing IDs: GHSA-74fp-r6jw-h4mp Record: https://patchnext.com/advisories/ghsa-74fp-r6jw-h4mp (revision 1, source checked 26 Oct 2026, 15:04 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: k8s.io/apimachinery 0.0.0-20190927203648-9ce6eca90e73. A vendor fix does not mean a deployment is fixed. ## Affected components - Go k8s.io/apimachinery: affected < 0.0.0-20190927203648-9ce6eca90e73; fixed in 0.0.0-20190927203648-9ce6eca90e73 ## Suggested inspection (read-only) - Go k8s.io/apimachinery: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on k8s.io/apimachinery. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-74fp-r6jw-h4mp (GitHub-reviewed advisory GHSA-74fp-r6jw-h4mp lists affected ranges: Go k8s.io/apimachinery >=0 <0.0.0-20190927203648-9ce6eca90e73) Commands are suggestions: review each one before running it.
Loading voting…