Skip to content

← Actionable
Unratedamended

Sensitive Data Exposure in loopback

GHSA-724c-6vrf-99rq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (loopback 3.26.0, 2.42.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm loopback

    Affected
    <= 2.41.0>= 3.0.0, <= 3.25.0
    Fixed in
    2.42.0, 3.26.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Versions of loopback prior to 3.26.0 (3.x) and 2.42.0 (2.x) are vulnerable to Sensitive Data Exposure. Invalid API requests to the login endpoint may return information about the first user in the database. This can be used alongside other attacks for credential theft. Recommendation If you're using loopback 3.x upgrade to version 3.26.0 or later. If you're using loopback 2.x upgrade to version 2.42.0 or later.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-724c-6vrf-99rq

  2. Revision 1 · created ·

    Published from osv record GHSA-724c-6vrf-99rq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-724c-6vrf-99rq

Advisory: Sensitive Data Exposure in loopback
IDs: GHSA-724c-6vrf-99rq
Record: https://patchnext.com/advisories/ghsa-724c-6vrf-99rq (revision 2, source checked 26 Oct 2026, 12:08 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: loopback 3.26.0, 2.42.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm loopback: affected <= 2.41.0; >= 3.0.0, <= 3.25.0; fixed in 2.42.0, 3.26.0

## Suggested inspection (read-only)
- `npm ls loopback --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on loopback.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-724c-6vrf-99rq (OSV record GHSA-724c-6vrf-99rq lists affected ranges: npm loopback >=0 =3.0.0 <3.26.0 (fixed))
- Verified: https://github.com/advisories/GHSA-724c-6vrf-99rq (GitHub-reviewed advisory GHSA-724c-6vrf-99rq lists affected ranges: npm loopback >=0 =3.0.0 <=3.25.0)

Commands are suggestions: review each one before running it.

Loading voting…