Shopware vulnerable to path traversal via Plugin upload
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (shopware/core 6.7.3.1, 6.6.10.7; shopware/platform 6.7.3.1, 6.6.10.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist shopware/core
- Affected
- >= 6.7.0.0, < 6.7.3.1< 6.6.10.7
- Fixed in
- 6.7.3.1, 6.6.10.7
Packagist shopware/platform
- Affected
- >= 6.7.0.0, < 6.7.3.1< 6.6.10.7
- Fixed in
- 6.7.3.1, 6.6.10.7
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6wh5-mw9h-5c3w lists affected ranges: Packagist shopware/platform >=6.7.0.0 =0 =6.7.0.0 =0 <6.6.10.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 2.7 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:L/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact Malicious actors can exploit this vulnerability to write files within arbitrary directories on the filesystem of the Shopware web container. This could allow them to gain persistent shell access by uploading a PHP-shell file to an accessible folder. It is important to note that this vulnerability is only present on on-premises installation of Shopware and not present on the SaaS installation due to additional security checks being implemented on the uploaded plugin files. Description A path traversal vulnerability allows malicious actors to access files and folders that are outside the folder structure accessible to the affected function. This vulnerability occurs when an application uses unfiltered user input to point to the path of a specific file and retrieve it. This can result in gaining read/write access to sensitive information, application code, back-end systems and other (critical) files on the operating system. In certain cases, it is even possible to store arbitrary…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-6wh5-mw9h-5c3w
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-6wh5-mw9h-5c3w Advisory: Shopware vulnerable to path traversal via Plugin upload IDs: GHSA-6wh5-mw9h-5c3w Record: https://patchnext.com/advisories/ghsa-6wh5-mw9h-5c3w (revision 1, source checked 26 Oct 2026, 14:34 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: shopware/core 6.7.3.1, 6.6.10.7; shopware/platform 6.7.3.1, 6.6.10.7. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist shopware/core: affected >= 6.7.0.0, < 6.7.3.1; < 6.6.10.7; fixed in 6.7.3.1, 6.6.10.7 - Packagist shopware/platform: affected >= 6.7.0.0, < 6.7.3.1; < 6.6.10.7; fixed in 6.7.3.1, 6.6.10.7 ## Suggested inspection (read-only) - Packagist shopware/core: check the installed version with your package manager. - Packagist shopware/platform: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on shopware/core, shopware/platform. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-6wh5-mw9h-5c3w (GitHub-reviewed advisory GHSA-6wh5-mw9h-5c3w lists affected ranges: Packagist shopware/platform >=6.7.0.0 =0 =6.7.0.0 =0 <6.6.10.7) Commands are suggestions: review each one before running it.
Loading voting…