Juju's unprivileged user running on charm node can leak any secret or relation data accessible to the local charm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/juju/juju 3.5.3, 3.4.5, 3.3.6, 3.1.9, 2.9.50), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 2.9.50>= 3.0.0, < 3.1.9>= 3.2.0, < 3.3.6>= 3.4.0, < 3.4.5>= 3.5.0, < 3.5.3
- Fixed in
- 3.5.3, 3.3.6, 2.9.50, 3.1.9, 3.4.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6vjm-54vp-mxhx lists affected ranges: Go github.com/juju/juju >=0 =3.0.0 =3.2.0 =3.4.0 =3.5.0 <3.5.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
An issue was discovered in Juju that resulted in the leak of the sensitive context ID, which allows a local unprivileged attacker to access other sensitive data or relation accessible to the local charm. A potential exploit where a user can run a bash loop attempting to execute hook tools. If running while another hook is executing, we log an error with the context ID, making it possible for the user to then use that ID in a following call successfully. This means an unprivileged user can access anything available via a hook tool such as config, relation data and secrets.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-6vjm-54vp-mxhx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-6vjm-54vp-mxhx Advisory: Juju's unprivileged user running on charm node can leak any secret or relation data accessible to the local charm IDs: GHSA-6vjm-54vp-mxhx Record: https://patchnext.com/advisories/ghsa-6vjm-54vp-mxhx (revision 1, source checked 26 Oct 2026, 15:04 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/juju/juju 3.5.3, 3.4.5, 3.3.6, 3.1.9, 2.9.50. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/juju/juju: affected < 2.9.50; >= 3.0.0, < 3.1.9; >= 3.2.0, < 3.3.6; >= 3.4.0, < 3.4.5; >= 3.5.0, < 3.5.3; fixed in 3.5.3, 3.3.6, 2.9.50, 3.1.9, 3.4.5 ## Suggested inspection (read-only) - Go github.com/juju/juju: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/juju/juju. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-6vjm-54vp-mxhx (GitHub-reviewed advisory GHSA-6vjm-54vp-mxhx lists affected ranges: Go github.com/juju/juju >=0 =3.0.0 =3.2.0 =3.4.0 =3.5.0 <3.5.3) Commands are suggestions: review each one before running it.
Loading voting…