Nodemailer: Process-global DNS cache reuses TLS servername across transports, enabling cross-tenant SMTP credential disclosure
CVE-2026-100701GHSA-6vj9-mwq6-2f5v
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (nodemailer 10.0.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm nodemailer
- Affected
- >= 5.0.0, < 10.0.2
- Fixed in
- 10.0.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6vj9-mwq6-2f5v lists affected ranges: npm nodemailer >=5.0.0 <10.0.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-6vj9-mwq6-2f5v lists affected ranges: npm nodemailer >=5.0.0 <10.0.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.9 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:L/A:N
- EPSS
- CVE-2026-100701: 0.11% estimated exploitation activity in the next 30 days; percentile 1.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Nodemailer's process-global DNS cache is keyed only by host, but each cache entry also stores the caller-specific TLS servername. When two direct SMTPS transports use the same DNS host with different tls.servername values, the first transport's server name is returned to the second transport and overwrites its explicitly configured value. As a result, Nodemailer sends the wrong SNI value and verifies the peer certificate against the wrong identity. In a multi-tenant service or SNI-routed SMTP gateway, one tenant can prime the cache so that a victim transport connects to the attacker's TLS virtual host, accepts the attacker's certificate with rejectUnauthorized: true, and sends the victim's SMTP credentials to it. Affected component - Ecosystem: npm - Package: nodemailer - Repository: https://github.com/nodemailer/nodemailer - Tested version: 10.0.1 - Tested commit: 40d52215aac65b811d7e131bc916f68605efd9d2 - Runtime-confirmed vulnerable versions: 5.0.0 and 10.0.1 - Affected…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-6vj9-mwq6-2f5v
- Revision 2 · amended ·
Amended from osv record GHSA-6vj9-mwq6-2f5v
- Revision 1 · created ·
Published from ghsa record GHSA-6vj9-mwq6-2f5v
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-100701 Advisory: Nodemailer: Process-global DNS cache reuses TLS `servername` across transports, enabling cross-tenant SMTP credential disclosure IDs: CVE-2026-100701, GHSA-6vj9-mwq6-2f5v Record: https://patchnext.com/advisories/ghsa-6vj9-mwq6-2f5v (revision 3, source checked 26 Oct 2026, 13:02 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: nodemailer 10.0.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm nodemailer: affected >= 5.0.0, < 10.0.2; fixed in 10.0.2 ## Suggested inspection (read-only) - `npm ls nodemailer --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on nodemailer. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-6vj9-mwq6-2f5v (GitHub-reviewed advisory GHSA-6vj9-mwq6-2f5v lists affected ranges: npm nodemailer >=5.0.0 <10.0.2) - Verified: https://osv.dev/vulnerability/GHSA-6vj9-mwq6-2f5v (OSV record GHSA-6vj9-mwq6-2f5v lists affected ranges: npm nodemailer >=5.0.0 <10.0.2 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…