Skip to content

← Actionable
High, CVSS 8.2amended

basic-ftp: Incomplete CRLF Injection Protection Allows Arbitrary FTP Command Execution via Credentials and MKD Commands

GHSA-6v7q-wjvx-w8wg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (basic-ftp 5.2.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.2 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:L
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary basic-ftp's CRLF injection protection (added in commit 2ecc8e2 for GHSA-chqc-8p9q-pq6q) is incomplete. Two code paths bypass the protectWhitespace() control character check: (1) the login() method directly concatenates user-supplied credentials into USER/PASS FTP commands without any validation, and (2) the openDir() method sends an MKD command before cd() invokes protectWhitespace(), creating a TOCTOU bypass. Both vectors allow an attacker who controls input to inject arbitrary FTP commands into the control connection. Details Vector 1: Credential Injection (login) The login() method constructs FTP commands by direct string concatenation with no CRLF validation: FtpContext.send() writes directly to the TCP socket: The protectWhitespace() method (line 762) rejects \r, \n, and \0 characters — but it is only called for path-based operations. Credentials never pass through it. The public access() method (line 268) passes options.user and options.password directly to login() with…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-6v7q-wjvx-w8wg

  2. Revision 1 · created ·

    Published from osv record GHSA-6v7q-wjvx-w8wg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-6v7q-wjvx-w8wg

Advisory: basic-ftp: Incomplete CRLF Injection Protection Allows Arbitrary FTP Command Execution via Credentials and MKD Commands
IDs: GHSA-6v7q-wjvx-w8wg
Record: https://patchnext.com/advisories/ghsa-6v7q-wjvx-w8wg (revision 2, source checked 26 Oct 2026, 12:48 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: basic-ftp 5.2.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm basic-ftp: affected <= 5.2.1; fixed in 5.2.2

## Suggested inspection (read-only)
- `npm ls basic-ftp --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on basic-ftp.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-6v7q-wjvx-w8wg (OSV record GHSA-6v7q-wjvx-w8wg lists affected ranges: npm basic-ftp >=0 <5.2.2 (fixed))
- Verified: https://github.com/advisories/GHSA-6v7q-wjvx-w8wg (GitHub-reviewed advisory GHSA-6v7q-wjvx-w8wg lists affected ranges: npm basic-ftp >=0 <=5.2.1)

Commands are suggestions: review each one before running it.

Loading voting…