Uncontrolled Recursion in SurrealQL Parsing
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (surrealdb 1.1.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io surrealdb
- Affected
- < 1.1.0
- Fixed in
- 1.1.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6r8p-hpg7-825g lists affected ranges: crates.io surrealdb >=0 <1.1.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
In some specific instances, the SurrealQL parser will attempt to recursively parse nested statements or idioms (i.e. nested IF and RELATE statements, nested basic idioms and nested access to attributes) without checking if the depth limit established by default or in the SURREALMAXCOMPUTATIONDEPTH environment variable is exceeded. This can lead to the stack overflowing when the nesting surpasses certain levels of depth. Impact An attacker that is authorized to run queries on a SurrealDB server may be able to run a query using the affected statements and idioms with very deep nesting in order to crash the server, leading to denial of service. Patches - Version 1.1.0 and later are not affected by this issue. Workarounds Concerned users unable to update may want to limit the ability of untrusted users to run arbitrary SurrealQL queries in the affected versions of SurrealDB. To limit the impact of the denial of service, SurrealDB administrators may also want to ensure that the SurrealDB…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-6r8p-hpg7-825g
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-6r8p-hpg7-825g Advisory: Uncontrolled Recursion in SurrealQL Parsing IDs: GHSA-6r8p-hpg7-825g Record: https://patchnext.com/advisories/ghsa-6r8p-hpg7-825g (revision 1, source checked 26 Oct 2026, 15:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: surrealdb 1.1.0. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io surrealdb: affected < 1.1.0; fixed in 1.1.0 ## Suggested inspection (read-only) - crates.io surrealdb: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on surrealdb. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-6r8p-hpg7-825g (GitHub-reviewed advisory GHSA-6r8p-hpg7-825g lists affected ranges: crates.io surrealdb >=0 <1.1.0) Commands are suggestions: review each one before running it.
Loading voting…