Skip to content

← Actionable
Medium, CVSS 6.5amended

CSRF Vulnerability in jquery-ujs

GHSA-6qqj-rx4w-r3cj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (jquery-ujs 1.0.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Versions 1.0.3 and earlier of jquery-ujs are vulnerable to an information leakage attack that may enable attackers to launch CSRF attacks, as it allows attackers to send CSRF tokens to external domains. When an attacker controls the href attribute of an anchor tag, or the action attribute of a form tag triggering a POST action, the attacker can set the href or action to " https://attacker.com". By prepending a space to the external domain, it causes jQuery to consider it a same origin request, resulting in the user's CSRF token being sent to the external domain. Recommendation Upgrade jquery-ujs to version 1.0.4 or later.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-6qqj-rx4w-r3cj

  2. Revision 1 · created ·

    Published from osv record GHSA-6qqj-rx4w-r3cj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-6qqj-rx4w-r3cj

Advisory: CSRF Vulnerability in jquery-ujs
IDs: GHSA-6qqj-rx4w-r3cj
Record: https://patchnext.com/advisories/ghsa-6qqj-rx4w-r3cj (revision 2, source checked 26 Oct 2026, 12:09 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: jquery-ujs 1.0.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm jquery-ujs: affected <= 1.0.3; fixed in 1.0.4

## Suggested inspection (read-only)
- `npm ls jquery-ujs --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on jquery-ujs.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-6qqj-rx4w-r3cj (OSV record GHSA-6qqj-rx4w-r3cj lists affected ranges: npm jquery-ujs >=0 <1.0.4 (fixed))
- Verified: https://github.com/advisories/GHSA-6qqj-rx4w-r3cj (GitHub-reviewed advisory GHSA-6qqj-rx4w-r3cj lists affected ranges: npm jquery-ujs >=0 <=1.0.3)

Commands are suggestions: review each one before running it.

Loading voting…