Doctrine SQL injection vulnerability
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (doctrine/orm 2.0.3, 1.2.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist doctrine/orm
- Affected
- >= 2.0.0, < 2.0.3>= 1.0.0, < 1.2.4
- Fixed in
- 2.0.3, 1.2.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6q9v-4hq6-5m67 lists affected ranges: Packagist doctrine/orm >=2.0.0 =1.0.0 <1.2.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Doctrine is prone to SQL injection vulnerability. Users of Doctrine 1.2 and 2 should update to the newly released versions of both libraries immediately. Both versions only include the security fix and no other changes to their previous versions 1.2.3 and 2.0.2. Affected versions are: - 1.2.3 and earlier for PostgreSQL and DB2 Dialects - 2.0.2 and earlier The security issue was found to affect the Doctrine\DBAL\Platforms\AbstractPlatform::modifyLimitQuery() function which does not cast input values for limit and offset to integer and allows malicious SQL to be executed if these parameters are passed into Doctrine 2 directly from request variables without previous cast to integer. Functionality building on top using limit queries in the ORM such as Doctrine\ORM\Query::setFirstResult() and Doctrine\ORM\Query::setMaxResults() are also affected by this security issue. The fix for this security issue breaks backwards compatibility for developers that extend the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-6q9v-4hq6-5m67
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-6q9v-4hq6-5m67 Advisory: Doctrine SQL injection vulnerability IDs: GHSA-6q9v-4hq6-5m67 Record: https://patchnext.com/advisories/ghsa-6q9v-4hq6-5m67 (revision 1, source checked 26 Oct 2026, 14:24 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: doctrine/orm 2.0.3, 1.2.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist doctrine/orm: affected >= 2.0.0, < 2.0.3; >= 1.0.0, < 1.2.4; fixed in 2.0.3, 1.2.4 ## Suggested inspection (read-only) - Packagist doctrine/orm: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on doctrine/orm. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-6q9v-4hq6-5m67 (GitHub-reviewed advisory GHSA-6q9v-4hq6-5m67 lists affected ranges: Packagist doctrine/orm >=2.0.0 =1.0.0 <1.2.4) Commands are suggestions: review each one before running it.
Loading voting…