Firefly II has Stored XSS in Audit Log Entry view via piggy bank name (ale.twig)
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (grumpydictator/firefly-iii 6.6.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist grumpydictator/firefly-iii
- Affected
- <= 6.6.2
- Fixed in
- 6.6.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6jq6-x4cx-qvcm lists affected ranges: Packagist grumpydictator/firefly-iii >=0 <=6.6.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Summary The Twig template resources/views/list/ale.twig renders the piggy bank name from AuditLogEntry.after.piggy using the |raw filter, bypassing Twig's auto-escaping. A piggy bank created with an HTML payload in its name executes arbitrary JavaScript in any browser viewing that transaction's audit log. Root Cause The |raw filter is required on the outer trans() call to preserve <span tags in the amount parameter (currency styling). However, this also disables escaping for the user-controlled name parameter. Vulnerable code (resources/views/list/ale.twig lines 107, 110): No HTML sanitization at storage time — PiggyBankStoreRequest only validates min:1|max:255|uniquePiggyBankForUser. Data Flow CSP Note The nonce-based CSP (script-src 'nonce-...' 'strict-dynamic') does not prevent this attack. Inline event handlers (onerror, onload) in HTML attributes are governed by script-src-attr, which is unrestricted in the current policy. The <img onerror=... payload bypasses the nonce…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-6jq6-x4cx-qvcm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-6jq6-x4cx-qvcm Advisory: Firefly II has Stored XSS in Audit Log Entry view via piggy bank name (ale.twig) IDs: GHSA-6jq6-x4cx-qvcm Record: https://patchnext.com/advisories/ghsa-6jq6-x4cx-qvcm (revision 1, source checked 26 Oct 2026, 14:49 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: grumpydictator/firefly-iii 6.6.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist grumpydictator/firefly-iii: affected <= 6.6.2; fixed in 6.6.3 ## Suggested inspection (read-only) - Packagist grumpydictator/firefly-iii: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on grumpydictator/firefly-iii. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-6jq6-x4cx-qvcm (GitHub-reviewed advisory GHSA-6jq6-x4cx-qvcm lists affected ranges: Packagist grumpydictator/firefly-iii >=0 <=6.6.2) Commands are suggestions: review each one before running it.
Loading voting…