Sandbox Breakout in realms-shim
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (realms-shim 1.2.0; ses 0.6.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm realms-shim
- Affected
- < 1.2.0
- Fixed in
- 1.2.0
npm ses
- Affected
- < 0.6.3
- Fixed in
- 0.6.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-6jg8-7333-554w lists affected ranges: npm realms-shim >=0 =0 <0.6.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6jg8-7333-554w lists affected ranges: npm realms-shim >=0 =0 <0.6.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Versions of realms-shim prior to 1.2.0 are vulnerable to a Sandbox Breakout. Reflect.construct can be used on the sandboxed Function constructor to reach the prototypes of the primal Realm, which may allow an attacker to escape the sandbox and execute arbitrary code. Recommendation Upgrade to version 1.2.0 or later.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-6jg8-7333-554w
- Revision 1 · created ·
Published from osv record GHSA-6jg8-7333-554w
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-6jg8-7333-554w Advisory: Sandbox Breakout in realms-shim IDs: GHSA-6jg8-7333-554w Record: https://patchnext.com/advisories/ghsa-6jg8-7333-554w (revision 2, source checked 26 Oct 2026, 12:07 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: realms-shim 1.2.0; ses 0.6.3. A vendor fix does not mean a deployment is fixed. ## Affected components - npm realms-shim: affected < 1.2.0; fixed in 1.2.0 - npm ses: affected < 0.6.3; fixed in 0.6.3 ## Suggested inspection (read-only) - `npm ls realms-shim --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls ses --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on realms-shim, ses. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-6jg8-7333-554w (OSV record GHSA-6jg8-7333-554w lists affected ranges: npm realms-shim >=0 =0 <0.6.3 (fixed)) - Verified: https://github.com/advisories/GHSA-6jg8-7333-554w (GitHub-reviewed advisory GHSA-6jg8-7333-554w lists affected ranges: npm realms-shim >=0 =0 <0.6.3) Commands are suggestions: review each one before running it.
Loading voting…