Skip to content

← Actionable
Low, CVSS 2.0

SimpleWebAuthn: Registration verification does not sufficiently ensure that attestation certificates chain to a trust anchor

GHSA-6hxq-p678-4hr2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@simplewebauthn/server 13.3.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
2.0 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:A/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary validateCertificatePath() does not verify that an attestation's certificate chain actually terminates at a configured trust anchor. When walking the chain it stops at the first self-signed certificate it finds (which could be user-supplied), and exits early. This happens before the configured Apple/Google/etc trust anchor (which is concatenated to the end of the chain) is reached. A user can therefore register a credential and have the server accept it as if it were backed by a genuine Apple / Android SafetyNet / Yubikey / etc. Details packages/server/src/helpers/validateCertificatePath.ts: The configured trust anchor is appended to the end of the untrusted chain (line 83): The walk then verifies each cert was signed by the next, but breaks on the first self-signed cert (lines 104–116): The success condition is therefore "the certs form an internally-consistent chain ending in some self-signed cert" Rather than "the chain terminates at one of the configured trust anchors."…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-6hxq-p678-4hr2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-6hxq-p678-4hr2

Advisory: SimpleWebAuthn: Registration verification does not sufficiently ensure that attestation certificates chain to a trust anchor
IDs: GHSA-6hxq-p678-4hr2
Record: https://patchnext.com/advisories/ghsa-6hxq-p678-4hr2 (revision 1, source checked 26 Oct 2026, 13:02 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @simplewebauthn/server 13.3.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @simplewebauthn/server: affected <= 13.3.1; fixed in 13.3.2

## Suggested inspection (read-only)
- `npm ls @simplewebauthn/server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @simplewebauthn/server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-6hxq-p678-4hr2 (GitHub-reviewed advisory GHSA-6hxq-p678-4hr2 lists affected ranges: npm @simplewebauthn/server >=0 <=13.3.1)

Commands are suggestions: review each one before running it.

Loading voting…