CakePHP allows direct access of prefixed controller actions
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (cakephp/cakephp 2.7.2, 2.6.11, 2.5.9, 2.4.99, 2.3.99, 2.2.99, 2.1.99, 2.0.99), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist cakephp/cakephp
- Affected
- >= 2.0.0, < 2.0.99>= 2.1.0, < 2.1.99>= 2.2.0, < 2.2.99>= 2.3.0, < 2.3.99>= 2.4.0, < 2.4.99>= 2.5.0, < 2.5.9>= 2.6.0, < 2.6.11>= 2.7.0, < 2.7.2
- Fixed in
- 2.6.11, 2.0.99, 2.4.99, 2.7.2, 2.2.99, 2.1.99, 2.3.99, 2.5.9
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6hg4-vp5q-47mw lists affected ranges: Packagist cakephp/cakephp >=2.0.0 =2.1.0 =2.2.0 =2.3.0 =2.4.0 =2.5.0 =2.6.0 =2.7.0 <2.7.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Unconventional URL paths would allow direct access to prefixed actions without setting the correct request parameters.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-6hg4-vp5q-47mw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-6hg4-vp5q-47mw Advisory: CakePHP allows direct access of prefixed controller actions IDs: GHSA-6hg4-vp5q-47mw Record: https://patchnext.com/advisories/ghsa-6hg4-vp5q-47mw (revision 1, source checked 26 Oct 2026, 13:56 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: cakephp/cakephp 2.7.2, 2.6.11, 2.5.9, 2.4.99, 2.3.99, 2.2.99, 2.1.99, 2.0.99. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist cakephp/cakephp: affected >= 2.0.0, < 2.0.99; >= 2.1.0, < 2.1.99; >= 2.2.0, < 2.2.99; >= 2.3.0, < 2.3.99; >= 2.4.0, < 2.4.99; >= 2.5.0, < 2.5.9; >= 2.6.0, < 2.6.11; >= 2.7.0, < 2.7.2; fixed in 2.6.11, 2.0.99, 2.4.99, 2.7.2, 2.2.99, 2.1.99, 2.3.99, 2.5.9 ## Suggested inspection (read-only) - Packagist cakephp/cakephp: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on cakephp/cakephp. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-6hg4-vp5q-47mw (GitHub-reviewed advisory GHSA-6hg4-vp5q-47mw lists affected ranges: Packagist cakephp/cakephp >=2.0.0 =2.1.0 =2.2.0 =2.3.0 =2.4.0 =2.5.0 =2.6.0 =2.7.0 <2.7.2) Commands are suggestions: review each one before running it.
Loading voting…