OpenSearch StackOverflow vulnerability
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.opensearch:opensearch 2.11.1, 1.3.14), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.opensearch:opensearch
- Affected
- < 1.3.14>= 2.0.0, < 2.11.1
- Fixed in
- 2.11.1, 1.3.14
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6g3j-p5g6-992f lists affected ranges: Maven org.opensearch:opensearch >=0 =2.0.0 <2.11.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact A flaw was discovered in OpenSearch, affecting the search API that allowed a specially crafted query string to cause a Stack Overflow and ultimately a Denial of Service. The issue was identified by Elastic Engineering and corresponds to security advisory ESA-2023-14 (CVE-2023-31419). Mitigation Versions 1.3.14 and 2.11.1 contain a fix for this issue. For more information If you have any questions or comments about this advisory, please contact AWS/Amazon Security via our issue reporting page (https://aws.amazon.com/security/vulnerability-reporting/) or directly via email to aws-security@amazon.com. Please do not create a public GitHub issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-6g3j-p5g6-992f
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-6g3j-p5g6-992f Advisory: OpenSearch StackOverflow vulnerability IDs: GHSA-6g3j-p5g6-992f Record: https://patchnext.com/advisories/ghsa-6g3j-p5g6-992f (revision 1, source checked 26 Oct 2026, 16:20 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.opensearch:opensearch 2.11.1, 1.3.14. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.opensearch:opensearch: affected < 1.3.14; >= 2.0.0, < 2.11.1; fixed in 2.11.1, 1.3.14 ## Suggested inspection (read-only) - Maven org.opensearch:opensearch: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.opensearch:opensearch. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-6g3j-p5g6-992f (GitHub-reviewed advisory GHSA-6g3j-p5g6-992f lists affected ranges: Maven org.opensearch:opensearch >=0 =2.0.0 <2.11.1) Commands are suggestions: review each one before running it.
Loading voting…