Skip to content

← Actionable
Low, CVSS 2.3amended

xxhash-rust: Safe xxh3 custom-secret API accepts too-short secret in release

GHSA-6g2r-675j-hx59

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (xxhash-rust 0.8.16), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
2.3 · CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

I have a minimized safe Rust witness for xxhash-rust 0.8.15. Safe public route: xxhashrust::xxh3::xxh364withsecret(&[0x41], &[]) The caller-side harness contains no unsafe code. Under release execution, the internal minimum custom-secret length predicate is enforced only by debugassert!. Release-Miri reports construction of a fixed-width reference beyond the empty secret allocation. Observed diagnostic: Undefined Behavior: constructing invalid value of type &[u8; 4]: encountered a dangling reference Local repair evidence: handling custom-secret slices shorter than the internal minimum before fixed-width secret reads makes the same safe short-secret harness pass under Linux release-Miri. Local artifacts: - vulnerable log: artifacts/logs/W-4332xxhashrustshortsecretmirireleaselinux001.log - repair log: artifacts/logs/differentials/W-4332xxhashrustlocalrepairmirireleaselinux001.log - report: artifacts/reports/W-4332xxhashrustshortsecretreport.md

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-6g2r-675j-hx59

  2. Revision 1 · created ·

    Published from osv record GHSA-6g2r-675j-hx59

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-6g2r-675j-hx59

Advisory: xxhash-rust: Safe xxh3 custom-secret API accepts too-short secret in release
IDs: GHSA-6g2r-675j-hx59
Record: https://patchnext.com/advisories/ghsa-6g2r-675j-hx59 (revision 2, source checked 26 Oct 2026, 15:43 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: xxhash-rust 0.8.16. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io xxhash-rust: affected < 0.8.16; fixed in 0.8.16

## Suggested inspection (read-only)
- crates.io xxhash-rust: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on xxhash-rust.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-6g2r-675j-hx59 (OSV record GHSA-6g2r-675j-hx59 lists affected ranges: crates.io xxhash-rust >=0 <0.8.16 (fixed))
- Verified: https://github.com/advisories/GHSA-6g2r-675j-hx59 (GitHub-reviewed advisory GHSA-6g2r-675j-hx59 lists affected ranges: crates.io xxhash-rust >=0 <0.8.16)

Commands are suggestions: review each one before running it.

Loading voting…