Skip to content

← Actionable
Critical, CVSS 9.8

Zendframework1 Potential SQL injection in ORDER and GROUP functions

GHSA-6fqw-j3vm-7f66

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (zendframework/zendframework1 1.12.20), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

The implementation of ORDER BY and GROUP BY in ZendDbSelect remained prone to SQL injection when a combination of SQL expressions and comments were used. This security patch provides a comprehensive solution that identifies and removes comments prior to checking validity of the statement to ensure no SQLi vectors occur. The implementation of ORDER BY and GROUP BY in ZendDbSelect of ZF1 is vulnerable by the following SQL injection: The above $select will render the following SQL statement: instead of the correct one: This security fix can be considered an improvement of the previous ZF2016-02 and ZF2014-04 advisories. As a final consideration, we recommend developers either never use user input for these operations, or filter user input thoroughly prior to invoking ZendDb. You can use the ZendDbSelect::quoteInto() method to filter the input data, as shown in this example:

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-6fqw-j3vm-7f66

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-6fqw-j3vm-7f66

Advisory: Zendframework1 Potential SQL injection in ORDER and GROUP functions
IDs: GHSA-6fqw-j3vm-7f66
Record: https://patchnext.com/advisories/ghsa-6fqw-j3vm-7f66 (revision 1, source checked 26 Oct 2026, 14:25 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: zendframework/zendframework1 1.12.20. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist zendframework/zendframework1: affected < 1.12.20; fixed in 1.12.20

## Suggested inspection (read-only)
- Packagist zendframework/zendframework1: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on zendframework/zendframework1.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-6fqw-j3vm-7f66 (GitHub-reviewed advisory GHSA-6fqw-j3vm-7f66 lists affected ranges: Packagist zendframework/zendframework1 >=0 <1.12.20)

Commands are suggestions: review each one before running it.

Loading voting…