Cross-site Scripting vulnerabilities in Neos
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (neos/neos 2.0.4, 1.2.13), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist neos/neos
- Affected
- >= 1.2.0, < 1.2.13>= 2.0.0, < 2.0.4
- Fixed in
- 2.0.4, 1.2.13
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6cj3-rc4p-f38f lists affected ranges: Packagist neos/neos >=1.2.0 =2.0.0 <2.0.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
It has been discovered that Neos is vulnerable to several XSS attacks. Through these vulnerabilities, an attacker could tamper with page rendering, redirect victims to a fake login page, or capture user credentials (such as cookies). With the potential backdoor upload an attacker could gain access to the server itself, to an extent mainly limited by the server setup. Reflected Cross-Site Scripting (SXSS) with authentication A Neos backend user with permission to modify content can insert JavaScript instructions into content elements. The browser will execute the script in "Print" preview mode. A Neos backend user who can modify his profile information ("Title", "First Name", "Last name", "Middle Name", "Other Name") can inject JavaScript instructions in those parameters. Once set up, an administrator who wants to edit this user account will execute the code. Both attack vectors require a valid Neos backend user account. Reflected Cross-Site Scripting (RXSS) without authentication A…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-6cj3-rc4p-f38f
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-6cj3-rc4p-f38f Advisory: Cross-site Scripting vulnerabilities in Neos IDs: GHSA-6cj3-rc4p-f38f Record: https://patchnext.com/advisories/ghsa-6cj3-rc4p-f38f (revision 1, source checked 26 Oct 2026, 14:24 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: neos/neos 2.0.4, 1.2.13. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist neos/neos: affected >= 1.2.0, < 1.2.13; >= 2.0.0, < 2.0.4; fixed in 2.0.4, 1.2.13 ## Suggested inspection (read-only) - Packagist neos/neos: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on neos/neos. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-6cj3-rc4p-f38f (GitHub-reviewed advisory GHSA-6cj3-rc4p-f38f lists affected ranges: Packagist neos/neos >=1.2.0 =2.0.0 <2.0.4) Commands are suggestions: review each one before running it.
Loading voting…