yt-dlp: Arbitrary command injection possible if --exec option used with yt-dlp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (yt-dlp 2026.6.9), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI yt-dlp
- Affected
- >= 2021.4.11, < 2026.6.9
- Fixed in
- 2026.6.9
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-69qj-pvh9-c5wg lists affected ranges: PyPI yt-dlp >=2021.4.11 <2026.6.9 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-69qj-pvh9-c5wg lists affected ranges: PyPI yt-dlp >=2021.4.11 <2026.6.9
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Summary yt-dlp's --exec option is vulnerable to arbitrary command injection when handling untrusted metadata if the argument uses standard string formatting (e.g. %(title)s) or other unsafe conversions. An attacker could achieve remote code execution on the user's machine via maliciously crafted metadata containing quotes or other special shell characters. Details Since yt-dlp version 2021.04.11, the --exec option has supported "output template syntax", which is a superset of Python's printf-style string formatting also used by the --output option. This means the user is able to pass a "command template" as an argument to the --exec option which will be executed by the user's shell. The command template allows for the downloaded video's metadata to be interpolated into the command string. yt-dlp implements a %()q conversion, which will shell-quote/escape any metadata value such that it is safe to be interpolated into a command string. However, there are unsafe conversions such as…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-69qj-pvh9-c5wg
- Revision 1 · created ·
Published from osv record GHSA-69qj-pvh9-c5wg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-69qj-pvh9-c5wg Advisory: yt-dlp: Arbitrary command injection possible if --exec option used with yt-dlp IDs: GHSA-69qj-pvh9-c5wg Record: https://patchnext.com/advisories/ghsa-69qj-pvh9-c5wg (revision 2, source checked 26 Oct 2026, 13:45 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: yt-dlp 2026.6.9. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI yt-dlp: affected >= 2021.4.11, < 2026.6.9; fixed in 2026.6.9 ## Suggested inspection (read-only) - `python -m pip show yt-dlp`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on yt-dlp. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-69qj-pvh9-c5wg (OSV record GHSA-69qj-pvh9-c5wg lists affected ranges: PyPI yt-dlp >=2021.4.11 <2026.6.9 (fixed)) - Verified: https://github.com/advisories/GHSA-69qj-pvh9-c5wg (GitHub-reviewed advisory GHSA-69qj-pvh9-c5wg lists affected ranges: PyPI yt-dlp >=2021.4.11 <2026.6.9) Commands are suggestions: review each one before running it.
Loading voting…