Litestar has potential log injection in exception logging
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (litestar 2.17.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI litestar
- Affected
- <= 2.16.0
- Fixed in
- 2.17.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-674p-xv2x-rf3g lists affected ranges: PyPI litestar >=0 <2.17.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-674p-xv2x-rf3g lists affected ranges: PyPI litestar >=0 <=2.16.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Summary Litestar does not escape url paths when logging exceptions. This makes logger vulnerable to CRLF injection if logging level is configured to debug or logexceptions is set to "always", which allows attackers to inject newlines and forge log entries. Details Litestar directly formats unquoted path into exception logs without validation or escaping when using default exception logging handler. https://github.com/litestar-org/litestar/blob/1e0dc7c4d67151c836208a3e360051e983b5083a/litestar/logging/config.py#L145-L150 Attackers can inject newlines in logs by embedding%0d%0a in url path. logexceptions="always" is not enabled by default. However, it is set in the examples of documentation (https://github.com/litestar-org/litestar/blob/1e0dc7c4d67151c836208a3e360051e983b5083a/docs/usage/logging.rst#logging). User will be impacted if they directly copy the logging config from docs. PoC logging: If stacktracks for 404 are configured to be ignored (disablestacktrace={404},), attacker may…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-674p-xv2x-rf3g
- Revision 1 · created ·
Published from osv record GHSA-674p-xv2x-rf3g
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-674p-xv2x-rf3g Advisory: Litestar has potential log injection in exception logging IDs: GHSA-674p-xv2x-rf3g Record: https://patchnext.com/advisories/ghsa-674p-xv2x-rf3g (revision 2, source checked 26 Oct 2026, 13:32 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: litestar 2.17.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI litestar: affected <= 2.16.0; fixed in 2.17.0 ## Suggested inspection (read-only) - `python -m pip show litestar`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on litestar. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-674p-xv2x-rf3g (OSV record GHSA-674p-xv2x-rf3g lists affected ranges: PyPI litestar >=0 <2.17.0 (fixed)) - Verified: https://github.com/advisories/GHSA-674p-xv2x-rf3g (GitHub-reviewed advisory GHSA-674p-xv2x-rf3g lists affected ranges: PyPI litestar >=0 <=2.16.0) Commands are suggestions: review each one before running it.
Loading voting…