Member account takeover
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ghost 4.15.1, 3.42.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm ghost
- Affected
- >= 3.18.0, < 3.42.6>= 4.0.0, < 4.15.1
- Fixed in
- 4.15.1, 3.42.6
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-65p7-pjj8-ggmr lists affected ranges: npm ghost >=3.18.0 =4.0.0 <4.15.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-65p7-pjj8-ggmr lists affected ranges: npm ghost >=3.18.0 =4.0.0 <4.15.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact An error in the implementation of the member email change functionality allows unauthenticated users to change the email address of arbitrary member accounts to one they control by crafting a request to the relevant API endpoint, and validating the new address via magic link sent to the new email address. Ghost(Pro) has already been patched. Self-hosters are impacted if running Ghost a version between 3.18.0 and 4.15.0 with members functionality enabled. Patches Fixed in 4.15.1, all 4.x sites should upgrade as soon as possible. Fixed in 3.42.6, all 3.x sites should upgrade as soon as possible. Workarounds The patch in 4.15.1 and 3.42.6 adds a new authenticated endpoint for updating member email addresses. Updating Ghost is the quickest complete solution. As a workaround, if for any reason you cannot update your Ghost instance, you can block the POST /members/api/send-magic-link/ endpoint, which will also disable member login and signup for your site. For more information If…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-65p7-pjj8-ggmr
- Revision 1 · created ·
Published from osv record GHSA-65p7-pjj8-ggmr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-65p7-pjj8-ggmr Advisory: Member account takeover IDs: GHSA-65p7-pjj8-ggmr Record: https://patchnext.com/advisories/ghsa-65p7-pjj8-ggmr (revision 2, source checked 26 Oct 2026, 12:15 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ghost 4.15.1, 3.42.6. A vendor fix does not mean a deployment is fixed. ## Affected components - npm ghost: affected >= 3.18.0, < 3.42.6; >= 4.0.0, < 4.15.1; fixed in 4.15.1, 3.42.6 ## Suggested inspection (read-only) - `npm ls ghost --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ghost. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-65p7-pjj8-ggmr (OSV record GHSA-65p7-pjj8-ggmr lists affected ranges: npm ghost >=3.18.0 =4.0.0 <4.15.1 (fixed)) - Verified: https://github.com/advisories/GHSA-65p7-pjj8-ggmr (GitHub-reviewed advisory GHSA-65p7-pjj8-ggmr lists affected ranges: npm ghost >=3.18.0 =4.0.0 <4.15.1) Commands are suggestions: review each one before running it.
Loading voting…