eZ Platform Object Injection in SiteAccessMatchListener
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ezsystems/ezpublish-kernel 7.5.8, 6.13.6.4, 5.4.15), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist ezsystems/ezpublish-kernel
- Affected
- >= 7.5.0, < 7.5.8>= 6.13.0, < 6.13.6.4>= 5.4.0, < 5.4.15
- Fixed in
- 7.5.8, 5.4.15, 6.13.6.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-64vj-933f-6pm3 lists affected ranges: Packagist ezsystems/ezpublish-kernel >=7.5.0 =6.13.0 =5.4.0 <5.4.15
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
This Security Advisory is about an object injection vulnerability in the SiteAccessMatchListener of eZ Platform, which could lead to remote code execution (RCE), a very serious threat. All sites may be affected. Update: There are bugs introduced by this fix, particularly but not limited to compound siteaccess matchers. These have been fixed in ezsystems/ezplatform-kernel v1.0.3, and in ezsystems/ezpublish-kernel v7.5.8, v6.13.6.4, and v5.4.15.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-64vj-933f-6pm3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-64vj-933f-6pm3 Advisory: eZ Platform Object Injection in SiteAccessMatchListener IDs: GHSA-64vj-933f-6pm3 Record: https://patchnext.com/advisories/ghsa-64vj-933f-6pm3 (revision 1, source checked 26 Oct 2026, 14:24 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ezsystems/ezpublish-kernel 7.5.8, 6.13.6.4, 5.4.15. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist ezsystems/ezpublish-kernel: affected >= 7.5.0, < 7.5.8; >= 6.13.0, < 6.13.6.4; >= 5.4.0, < 5.4.15; fixed in 7.5.8, 5.4.15, 6.13.6.4 ## Suggested inspection (read-only) - Packagist ezsystems/ezpublish-kernel: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ezsystems/ezpublish-kernel. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-64vj-933f-6pm3 (GitHub-reviewed advisory GHSA-64vj-933f-6pm3 lists affected ranges: Packagist ezsystems/ezpublish-kernel >=7.5.0 =6.13.0 =5.4.0 <5.4.15) Commands are suggestions: review each one before running it.
Loading voting…