Skip to content

← Actionable
Medium, CVSS 6.9

Cross Site Scripting (XSS) vulnerability while uploading content to a new deployment

GHSA-64gp-r758-8pfm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.jboss.hal:hal-console 3.7.7.Final), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N · score source
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

A vulnerability was found in the WildFly management console. A user may perform cross-site scripting in the deployment system. An attacker (or insider) may execute a malicious payload which could trigger an undesired behavior against the server. Impact Cross-site scripting (XSS) vulnerability in the management console. Patches Fixed in HAL 3.7.7.Final Workarounds No workaround available References See also: https://issues.redhat.com/browse/WFLY-19969

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-64gp-r758-8pfm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-64gp-r758-8pfm

Advisory: Cross Site Scripting (XSS) vulnerability while uploading content to a new deployment
IDs: GHSA-64gp-r758-8pfm
Record: https://patchnext.com/advisories/ghsa-64gp-r758-8pfm (revision 1, source checked 26 Oct 2026, 16:34 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.jboss.hal:hal-console 3.7.7.Final. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.jboss.hal:hal-console: affected < 3.7.7.Final; fixed in 3.7.7.Final

## Suggested inspection (read-only)
- Maven org.jboss.hal:hal-console: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.jboss.hal:hal-console.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-64gp-r758-8pfm (GitHub-reviewed advisory GHSA-64gp-r758-8pfm lists affected ranges: Maven org.jboss.hal:hal-console >=0 <3.7.7.Final)

Commands are suggestions: review each one before running it.

Loading voting…