Skip to content

← Actionable
High, CVSS 8.7

Untrusted Query Object Evaluation in RPC API

GHSA-64f8-pjgr-9wmr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (surrealdb 2.0.0-beta.3, 1.5.5; surrealdb-core 1.5.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io surrealdb

    Affected
    < 1.5.5>= 2.0.0-beta.1, < 2.0.0-beta.3
    Fixed in
    2.0.0-beta.3, 1.5.5
  • crates.io surrealdb-core

    Affected
    < 1.5.2
    Fixed in
    1.5.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

During the sign in and sign up operations through the SurrealDB RPC API, an arbitrary object would be accepted in order to support a wide array of types and structures that could contain user credentials. This arbitrary object could potentially contain any SurrealDB value, including an object representing a subquery. For this to materialize, this object would need to be encoded using the bincode serialization format instead of the default JSON serialization format or the additionally supported CBOR serialization format. If a binary object containing a subquery were to be provided in this way, that subquery would be computed while executing the SIGNIN and SIGNUP queries defined by the database owner while defining a record access method. Since those queries are executed under a system user session with the editor role, an unauthenticated attacker may be able to leverage this behavior to select, create, update and delete non-IAM resources with permissions of a system user with the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-64f8-pjgr-9wmr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-64f8-pjgr-9wmr

Advisory: Untrusted Query Object Evaluation in RPC API
IDs: GHSA-64f8-pjgr-9wmr
Record: https://patchnext.com/advisories/ghsa-64f8-pjgr-9wmr (revision 1, source checked 26 Oct 2026, 15:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: surrealdb 2.0.0-beta.3, 1.5.5; surrealdb-core 1.5.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io surrealdb: affected < 1.5.5; >= 2.0.0-beta.1, < 2.0.0-beta.3; fixed in 2.0.0-beta.3, 1.5.5
- crates.io surrealdb-core: affected < 1.5.2; fixed in 1.5.2

## Suggested inspection (read-only)
- crates.io surrealdb: check the installed version with your package manager.
- crates.io surrealdb-core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on surrealdb, surrealdb-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-64f8-pjgr-9wmr (GitHub-reviewed advisory GHSA-64f8-pjgr-9wmr lists affected ranges: crates.io surrealdb >=0 =2.0.0-beta.1 =0 <1.5.2)

Commands are suggestions: review each one before running it.

Loading voting…