@grackle-ai/mcp has a workspace authorization bypass in its knowledge_search MCP tool
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@grackle-ai/mcp 0.70.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @grackle-ai/mcp
- Affected
- <= 0.70.1
- Fixed in
- 0.70.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-647h-p824-99w7 lists affected ranges: npm @grackle-ai/mcp >=0 <0.70.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-647h-p824-99w7 lists affected ranges: npm @grackle-ai/mcp >=0 <=0.70.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact The knowledgesearch and knowledgegetnode MCP tools are included in SCOPEDTOOLS (visible to scoped agents) but their handlers do not receive authContext and do not enforce workspace scoping. A scoped agent in Workspace A can supply an arbitrary workspaceId parameter to search or retrieve knowledge graph nodes from Workspace B, bypassing workspace isolation boundaries. This is a cross-workspace data leakage vulnerability affecting any deployment where multiple workspaces contain sensitive knowledge graph data and scoped agents are used. Affected code: - packages/mcp/src/tools/knowledge.ts:146-169 (knowledgesearch handler) - packages/mcp/src/tools/knowledge.ts:244-283 (knowledgegetnode handler) - packages/mcp/src/tool-scoping.ts:11 (both tools listed in SCOPEDTOOLS) Contrast with correct implementation: knowledgecreatenode (same file, lines 334-357) properly receives authContext and overrides the user-supplied workspaceId for scoped callers. Design Note Cross-workspace knowledge…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-647h-p824-99w7
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-647h-p824-99w7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-647h-p824-99w7 Advisory: @grackle-ai/mcp has a workspace authorization bypass in its knowledge_search MCP tool IDs: GHSA-647h-p824-99w7 Record: https://patchnext.com/advisories/ghsa-647h-p824-99w7 (revision 3, source checked 26 Oct 2026, 12:46 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @grackle-ai/mcp 0.70.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @grackle-ai/mcp: affected <= 0.70.1; fixed in 0.70.2 ## Suggested inspection (read-only) - `npm ls @grackle-ai/mcp --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @grackle-ai/mcp. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-647h-p824-99w7 (OSV record GHSA-647h-p824-99w7 lists affected ranges: npm @grackle-ai/mcp >=0 <0.70.2 (fixed)) - Verified: https://github.com/advisories/GHSA-647h-p824-99w7 (GitHub-reviewed advisory GHSA-647h-p824-99w7 lists affected ranges: npm @grackle-ai/mcp >=0 <=0.70.1) Commands are suggestions: review each one before running it.
Loading voting…