Skip to content

← Actionable
Low, CVSS 3.7amended

AWS SDK for JavaScript v3 adopted defense in depth enhancement for region parameter value

GHSA-6475-r3vj-m8vf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@smithy/config-resolver 4.4.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

CVSSv3.1 Rating: 3.7 (LOW) Summary This notification is related to the use of specific values for the region input field when calling AWS services. An actor with access to the environment in which the SDK is used could set the region input field to an invalid value. A defense-in-depth enhancement has been implemented in the AWS SDK for JavaScript v3 (versions 3.723.0 and later). This enhancement validates that a region used to construct an endpoint URL is a valid host label. The change was released on November 15, 2025. This advisory is informational to help customers understand their responsibilities regarding configuration security. Impact Customer applications could be configured to improperly route AWS API calls to non-existent or non-AWS hosts. While the SDK was functioning as designed, additional safeguards have been added to support secure customer implementations. Impacted versions: @smithy/config-resolver <4.4.0 Patches On November 15, 2025, an enhancement was made to the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-6475-r3vj-m8vf

  2. Revision 1 · created ·

    Published from osv record GHSA-6475-r3vj-m8vf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-6475-r3vj-m8vf

Advisory: AWS SDK for JavaScript v3 adopted defense in depth enhancement for region parameter value
IDs: GHSA-6475-r3vj-m8vf
Record: https://patchnext.com/advisories/ghsa-6475-r3vj-m8vf (revision 2, source checked 26 Oct 2026, 12:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @smithy/config-resolver 4.4.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @smithy/config-resolver: affected < 4.4.0; fixed in 4.4.0

## Suggested inspection (read-only)
- `npm ls @smithy/config-resolver --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @smithy/config-resolver.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-6475-r3vj-m8vf (OSV record GHSA-6475-r3vj-m8vf lists affected ranges: npm @smithy/config-resolver >=0 <4.4.0 (fixed))
- Verified: https://github.com/advisories/GHSA-6475-r3vj-m8vf (GitHub-reviewed advisory GHSA-6475-r3vj-m8vf lists affected ranges: npm @smithy/config-resolver >=0 <4.4.0)

Commands are suggestions: review each one before running it.

Loading voting…