mitmproxy binaries embed a vulnerable python-hyper/h2 dependency
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (mitmproxy 12.1.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI mitmproxy
- Affected
- <= 12.1.1
- Fixed in
- 12.1.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-63cx-g855-hvv4 lists affected ranges: PyPI mitmproxy >=0 <12.1.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-63cx-g855-hvv4 lists affected ranges: PyPI mitmproxy >=0 <=12.1.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:N/SI:L/SA:N · score source
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
mitmproxy 12.1.1 and below embed python-hyper/h2 ≤ v4.2.0, which has a gap in its HTTP/2 header validation. This enables request smuggling attacks when mitmproxy is in a configuration where it translates HTTP/2 to HTTP/1. For example, this affects reverse proxies to http:// backends. It does not affect mitmproxy's regular mode. All users are encouraged to upgrade to mitmproxy 12.1.2, which includes a fixed version of h2. More details about the vulnerability itself can be found at https://github.com/python-hyper/h2/security/advisories/GHSA-847f-9342-265h.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-63cx-g855-hvv4
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-63cx-g855-hvv4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-63cx-g855-hvv4 Advisory: mitmproxy binaries embed a vulnerable python-hyper/h2 dependency IDs: GHSA-63cx-g855-hvv4 Record: https://patchnext.com/advisories/ghsa-63cx-g855-hvv4 (revision 3, source checked 26 Oct 2026, 13:32 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: mitmproxy 12.1.2. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI mitmproxy: affected <= 12.1.1; fixed in 12.1.2 ## Suggested inspection (read-only) - `python -m pip show mitmproxy`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on mitmproxy. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-63cx-g855-hvv4 (OSV record GHSA-63cx-g855-hvv4 lists affected ranges: PyPI mitmproxy >=0 <12.1.2 (fixed)) - Verified: https://github.com/advisories/GHSA-63cx-g855-hvv4 (GitHub-reviewed advisory GHSA-63cx-g855-hvv4 lists affected ranges: PyPI mitmproxy >=0 <=12.1.1) Commands are suggestions: review each one before running it.
Loading voting…