Setup PHP: GitHub tokens configured by setup-php may be exposed through pinned affected Composer versions
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (shivammathur/setup-php 2.37.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
GitHub Actions shivammathur/setup-php
- Affected
- < 2.37.1
- Fixed in
- 2.37.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5wxr-w449-57cm lists affected ranges: GitHub Actions shivammathur/setup-php >=0 <2.37.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact This affects only workflows that pin an exact affected Composer semver version through setup-php, for example tools: composer:2.9.7. Workflows using the default Composer version, composer:v2, or no pinned Composer version are not affected through setup-php, because those Composer URLs have been updated to patched Composer releases for all setup-php versions. setup-php does not directly print the token. The token may be exposed through Composer when Composer validates github-oauth auth and rejects GitHub's newer hyphen-containing token format. Public repository logs may expose the token. GitHub-hosted runner GITHUBTOKEN values expire after the job, but exposure may still matter during the token lifetime and for longer-lived GitHub App or user tokens. Patches setup-php 2.37.1 skips generated GitHub OAuth auth for pinned Composer versions affected by Composer GHSA-f9f8-rm49-7jv2 while preserving other Composer auth, including Packagist auth. Workarounds Upgrade to setup-php…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-5wxr-w449-57cm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-5wxr-w449-57cm Advisory: Setup PHP: GitHub tokens configured by setup-php may be exposed through pinned affected Composer versions IDs: GHSA-5wxr-w449-57cm Record: https://patchnext.com/advisories/ghsa-5wxr-w449-57cm (revision 1, source checked 26 Oct 2026, 17:08 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: shivammathur/setup-php 2.37.1. A vendor fix does not mean a deployment is fixed. ## Affected components - GitHub Actions shivammathur/setup-php: affected < 2.37.1; fixed in 2.37.1 ## Suggested inspection (read-only) - GitHub Actions shivammathur/setup-php: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on shivammathur/setup-php. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-5wxr-w449-57cm (GitHub-reviewed advisory GHSA-5wxr-w449-57cm lists affected ranges: GitHub Actions shivammathur/setup-php >=0 <2.37.1) Commands are suggestions: review each one before running it.
Loading voting…