Skip to content

← Actionable
Medium, CVSS 6.9amended

@cyclonedx/cdxgen: Maven project scanning may allow shell command injection through repository-controlled module paths

GHSA-5vwr-qchf-q4pf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@cyclonedx/cdxgen 12.4.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N · score source
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary A command injection vulnerability existed in the Maven scanning flow of cdxgen before version 12.4.3. When cdxgen scanned an attacker-controlled Maven project, repository-controlled paths could be used in the Maven command construction. In affected versions, some Maven invocations were executed with shell: true. A directory name containing shell metacharacters could therefore be interpreted by the shell instead of being treated only as a filesystem path. This could allow an attacker who controls a scanned repository to execute commands in the cdxgen process context. The issue affected both the CLI and server mode. The issue is patched in 12.4.3. Affected asset - Project: cdxgen - Tested version: 12.4.1 - Mode tested: server mode - Endpoint: POST /sbom - Scanner path: Java / Maven project scanning Patch Version 12.4.3 includes hardening for this issue with PR #4059 The patch adds multiple mitigations: - Maven command invocations no longer use unconditional shell execution on…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-5vwr-qchf-q4pf

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-5vwr-qchf-q4pf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-5vwr-qchf-q4pf

Advisory: @cyclonedx/cdxgen: Maven project scanning may allow shell command injection through repository-controlled module paths
IDs: GHSA-5vwr-qchf-q4pf
Record: https://patchnext.com/advisories/ghsa-5vwr-qchf-q4pf (revision 3, source checked 26 Oct 2026, 12:56 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @cyclonedx/cdxgen 12.4.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @cyclonedx/cdxgen: affected < 12.4.3; fixed in 12.4.3

## Suggested inspection (read-only)
- `npm ls @cyclonedx/cdxgen --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @cyclonedx/cdxgen.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-5vwr-qchf-q4pf (OSV record GHSA-5vwr-qchf-q4pf lists affected ranges: npm @cyclonedx/cdxgen >=0 <12.4.3 (fixed))
- Verified: https://github.com/advisories/GHSA-5vwr-qchf-q4pf (GitHub-reviewed advisory GHSA-5vwr-qchf-q4pf lists affected ranges: npm @cyclonedx/cdxgen >=0 <12.4.3)

Commands are suggestions: review each one before running it.

Loading voting…