Skip to content

← Actionable
High, CVSS 8.9

Laravel Framework: CRLF injection in default email rule

GHSA-5vg9-5847-vvmq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (laravel/framework 13.10.0, 12.60.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist laravel/framework

    Affected
    >= 13.0.0, <= 13.9.0< 12.60.0
    Fixed in
    12.60.0, 13.10.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:L
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary A CRLF injection vulnerability in Laravel's email validation, in combination with how Symfony Mailer and Symfony Mime handle certain character sequences, may allow an unauthenticated attacker to interfere with outbound email processing in applications that send mail to user-supplied addresses. Description Laravel applications that send email to addresses provided by users — for example during authentication flows or contact forms — may be vulnerable to manipulation of outbound mail content if the address is not adequately sanitized before it reaches the mail transport layer. An attacker who can supply an email address to such a flow may, under certain conditions, be able to influence the content of emails sent by the application, cause those emails to be delivered to unintended recipients, or cause the application's mail server to send unintended messages. Impact Affected applications may be exposed to unauthorized access and mail relay abuse. The severity depends on what the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-5vg9-5847-vvmq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-5vg9-5847-vvmq

Advisory: Laravel Framework: CRLF injection in default email rule
IDs: GHSA-5vg9-5847-vvmq
Record: https://patchnext.com/advisories/ghsa-5vg9-5847-vvmq (revision 1, source checked 26 Oct 2026, 14:49 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: laravel/framework 13.10.0, 12.60.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist laravel/framework: affected >= 13.0.0, <= 13.9.0; < 12.60.0; fixed in 12.60.0, 13.10.0

## Suggested inspection (read-only)
- Packagist laravel/framework: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on laravel/framework.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-5vg9-5847-vvmq (GitHub-reviewed advisory GHSA-5vg9-5847-vvmq lists affected ranges: Packagist laravel/framework >=13.0.0 =0 <12.60.0)

Commands are suggestions: review each one before running it.

Loading voting…