Insecure Cryptography Algorithm in simple-crypto-js
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (simple-crypto-js 2.3.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm simple-crypto-js
- Affected
- < 2.3.0
- Fixed in
- 2.3.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-5v7r-jg9r-vq44 lists affected ranges: npm simple-crypto-js >=0 <2.3.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5v7r-jg9r-vq44 lists affected ranges: npm simple-crypto-js >=0 <2.3.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Versions of simple-crypto-js prior to 2.3.0 use AES-CBC with PKCS#7 padding, which is vulnerable to padding oracle attacks. This may allow attackers to break the encryption and access sensitive data. Recommendation Upgrade to version 2.3.0 or later.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-5v7r-jg9r-vq44
- Revision 1 · created ·
Published from osv record GHSA-5v7r-jg9r-vq44
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-5v7r-jg9r-vq44 Advisory: Insecure Cryptography Algorithm in simple-crypto-js IDs: GHSA-5v7r-jg9r-vq44 Record: https://patchnext.com/advisories/ghsa-5v7r-jg9r-vq44 (revision 2, source checked 26 Oct 2026, 12:22 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: simple-crypto-js 2.3.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm simple-crypto-js: affected < 2.3.0; fixed in 2.3.0 ## Suggested inspection (read-only) - `npm ls simple-crypto-js --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on simple-crypto-js. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-5v7r-jg9r-vq44 (OSV record GHSA-5v7r-jg9r-vq44 lists affected ranges: npm simple-crypto-js >=0 <2.3.0 (fixed)) - Verified: https://github.com/advisories/GHSA-5v7r-jg9r-vq44 (GitHub-reviewed advisory GHSA-5v7r-jg9r-vq44 lists affected ranges: npm simple-crypto-js >=0 <2.3.0) Commands are suggestions: review each one before running it.
Loading voting…