Vibe-Trading file-read tools expose arbitrary server-readable files
CVE-2026-114106GHSA-5rmq-chc7-m22f
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (vibe-trading-ai 0.1.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI vibe-trading-ai
- Affected
- >= 0.1.0, < 0.1.7
- Fixed in
- 0.1.7
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5rmq-chc7-m22f lists affected ranges: PyPI vibe-trading-ai >=0.1.0 <0.1.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-5rmq-chc7-m22f lists affected ranges: PyPI vibe-trading-ai >=0.1.0 <0.1.7 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2026-114106: 0.43% estimated exploitation activity in the next 30 days; percentile 37.54 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary: 2 findings — safeuserpath() accepts any path under Path.home() or Path.cwd(), which inside the shipped root container resolves to /root and /app (so all of root's home, including /root/.ssh/idrsa, /root/.aws/credentials, /root/.kube/config, and /app/agent/.env, passes the check) (F9). readdocument() has no sandbox call at all and returns the full content of any path the FastAPI process can read, including /etc/shadow, /etc/passwd, /proc/self/environ, and any secret file mounted into the container (F10). F10 is strictly broader than F9 but they have different fix scopes (F10 = a missing safepath() call in one function; F9 = the envelope definition in pathutils.py), so both must be patched. --- Shared baseline (applies to both findings) The container has no USER directive (Dockerfile:15 — FROM python:3.11-slim AS runtime, no subsequent USER), so the FastAPI process runs as uid=0(root). The two file-read tools described here are members of the auto-discovered LLM tool registry.…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-5rmq-chc7-m22f
- Revision 2 · amended ·
Amended from osv record GHSA-5rmq-chc7-m22f
- Revision 1 · created ·
Published from ghsa record GHSA-5rmq-chc7-m22f
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-114106 Advisory: Vibe-Trading file-read tools expose arbitrary server-readable files IDs: CVE-2026-114106, GHSA-5rmq-chc7-m22f Record: https://patchnext.com/advisories/ghsa-5rmq-chc7-m22f (revision 3, source checked 26 Oct 2026, 13:54 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: vibe-trading-ai 0.1.7. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI vibe-trading-ai: affected >= 0.1.0, < 0.1.7; fixed in 0.1.7 ## Suggested inspection (read-only) - `python -m pip show vibe-trading-ai`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on vibe-trading-ai. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-5rmq-chc7-m22f (GitHub-reviewed advisory GHSA-5rmq-chc7-m22f lists affected ranges: PyPI vibe-trading-ai >=0.1.0 <0.1.7) - Verified: https://osv.dev/vulnerability/GHSA-5rmq-chc7-m22f (OSV record GHSA-5rmq-chc7-m22f lists affected ranges: PyPI vibe-trading-ai >=0.1.0 <0.1.7 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…