SageMaker Python SDK replaced eval() with safe parser in JumpStart search functionality
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (sagemaker 3.4.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI sagemaker
- Affected
- >= 3.0.0, < 3.4.0
- Fixed in
- 3.4.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-5r2p-pjr8-7fh7 lists affected ranges: PyPI sagemaker >=3.0.0 <3.4.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5r2p-pjr8-7fh7 lists affected ranges: PyPI sagemaker >=3.0.0 <3.4.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.4 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Summary This advisory addresses the use of the searchhub() function within the SageMaker Python SDK's JumpStart search functionality. An actor with the ability to control query parameters passed to the searchhub() function could potentially provide malformed input that causes the eval() function to execute arbitrary commands, access sensitive data, or compromise the execution environment. A defense-in-depth enhancement has been implemented to replace code evaluation with safe string operations when processing search query parameters. This enhancement removes the use of eval() from the execution path, replacing it with a safe recursive descent parser. The change was released in SageMaker Python SDK version 3.4.0 on January 23, 2026. This advisory is informational to help customers understand their responsibilities regarding input validation and configuration security under the AWS Shared Responsibility Model. Impact Customer applications that pass unsanitized or untrusted input…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-5r2p-pjr8-7fh7
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-5r2p-pjr8-7fh7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-5r2p-pjr8-7fh7 Advisory: SageMaker Python SDK replaced eval() with safe parser in JumpStart search functionality IDs: GHSA-5r2p-pjr8-7fh7 Record: https://patchnext.com/advisories/ghsa-5r2p-pjr8-7fh7 (revision 3, source checked 26 Oct 2026, 13:54 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: sagemaker 3.4.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI sagemaker: affected >= 3.0.0, < 3.4.0; fixed in 3.4.0 ## Suggested inspection (read-only) - `python -m pip show sagemaker`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on sagemaker. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-5r2p-pjr8-7fh7 (OSV record GHSA-5r2p-pjr8-7fh7 lists affected ranges: PyPI sagemaker >=3.0.0 <3.4.0 (fixed)) - Verified: https://github.com/advisories/GHSA-5r2p-pjr8-7fh7 (GitHub-reviewed advisory GHSA-5r2p-pjr8-7fh7 lists affected ranges: PyPI sagemaker >=3.0.0 <3.4.0) Commands are suggestions: review each one before running it.
Loading voting…