Skip to content

← Actionable
High, CVSS 8.6

OpenH264 Rust API Openh264 Decoding Functions Heap Overflow Vulnerability

GHSA-5pmw-9j92-3c4c

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openh264-sys2 0.8.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

OpenH264 recently reported a heap overflow that was fixed in upstream 63db555 and integrated into our 0.6.6 release. For users relying on Cisco's pre-compiled DLL, we also published 0.8.0, which is compatible with their latest fixed DLL version 2.6.0. In other words: - if you rely on our source feature only, =0.6.6 should be safe, - if you rely on libloading, you must upgrade to 0.8.0 and use their latest DLL =2.6.0. Users handling untrusted video files should update immediately.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-5pmw-9j92-3c4c

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-5pmw-9j92-3c4c

Advisory: OpenH264 Rust API Openh264 Decoding Functions Heap Overflow Vulnerability
IDs: GHSA-5pmw-9j92-3c4c
Record: https://patchnext.com/advisories/ghsa-5pmw-9j92-3c4c (revision 1, source checked 26 Oct 2026, 15:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openh264-sys2 0.8.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io openh264-sys2: affected < 0.8.0; fixed in 0.8.0

## Suggested inspection (read-only)
- crates.io openh264-sys2: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openh264-sys2.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-5pmw-9j92-3c4c (GitHub-reviewed advisory GHSA-5pmw-9j92-3c4c lists affected ranges: crates.io openh264-sys2 >=0 <0.8.0)

Commands are suggestions: review each one before running it.

Loading voting…