Skip to content

← Actionable
High, CVSS 7.5

JS-YAML: Quadratic CPU consumption in !!omap resolution (3.x and 4.x) — CVE-2026-59870 fix not backported

GHSA-5p4m-2wfm-xmqj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (js-yaml 4.3.1, 3.15.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm js-yaml

    Affected
    >= 4.0.0, < 4.3.1>= 3.0.0, < 3.15.1
    Fixed in
    4.3.1, 3.15.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Quadratic CPU consumption in !!omap resolution (js-yaml 3.x and 4.x) Summary resolveYamlOmap() enforces key uniqueness for !!omap sequences with a linear scan (objectKeys.indexOf(...)) inside the per-element loop, making resolution O(n²) in the number of entries. A modestly sized YAML document therefore consumes disproportionate CPU inside yaml.load(), giving a denial of service against any consumer that parses untrusted YAML. !!omap is registered in the default schema (lib/schema/default.js → require('../type/omap')), so a plain yaml.load(untrustedInput) with no options is affected — no custom schema or non-default configuration is required. This is the same weakness as CVE-2026-59870 / GHSA-724g-mxrg-4qvm, which was fixed in the 5.x line in 5.2.1. That fix was never backported: both currently maintained legacy lines still carry the original implementation. Affected versions | Line | Latest tested | Status | |---|---|---| | 3.x | 3.15.0 | Affected — objectKeys.indexOf(pairKey) at…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-5p4m-2wfm-xmqj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-5p4m-2wfm-xmqj

Advisory: JS-YAML: Quadratic CPU consumption in !!omap resolution (3.x and 4.x) — CVE-2026-59870 fix not backported
IDs: GHSA-5p4m-2wfm-xmqj
Record: https://patchnext.com/advisories/ghsa-5p4m-2wfm-xmqj (revision 1, source checked 26 Oct 2026, 13:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: js-yaml 4.3.1, 3.15.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm js-yaml: affected >= 4.0.0, < 4.3.1; >= 3.0.0, < 3.15.1; fixed in 4.3.1, 3.15.1

## Suggested inspection (read-only)
- `npm ls js-yaml --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on js-yaml.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-5p4m-2wfm-xmqj (GitHub-reviewed advisory GHSA-5p4m-2wfm-xmqj lists affected ranges: npm js-yaml >=4.0.0 =3.0.0 <3.15.1)

Commands are suggestions: review each one before running it.

Loading voting…