NextAuthjs Email misdelivery Vulnerability
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (next-auth 5.0.0-beta.30, 4.24.12), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm next-auth
- Affected
- < 4.24.12>= 5.0.0-beta.0, < 5.0.0-beta.30
- Fixed in
- 5.0.0-beta.30, 4.24.12
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-5jpx-9hw9-2fx4 lists affected ranges: npm next-auth >=0 =5.0.0-beta.0 <5.0.0-beta.30 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5jpx-9hw9-2fx4 lists affected ranges: npm next-auth >=0 =5.0.0-beta.0 <5.0.0-beta.30
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N/E:P · score source
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Summary NextAuth.js's email sign-in can be forced to deliver authentication emails to an attacker-controlled mailbox due to a bug in nodemailer's address parser used by the project (fixed in nodemailer v7.0.7). A crafted input such as: is parsed incorrectly and results in the message being delivered to e@attacker.com (attacker) instead of "<e@attacker.com@victim.com" (the intended recipient at victim.com) in violation of RFC 5321/5322 semantics. This allows an attacker to receive login/verification links or other sensitive emails intended for the victim. <h2Affected NextAuthjs Version</h2 ≤ Version | Afftected -- | -- 4.24.11 | Yes 5.0.0-beta.29 | Yes POC Example Setup showing misdelivery of email <img width="1247" height="1408" alt="Screenshot from 2025-10-25 21-15-25" src="https://github.com/user-attachments/assets/456968a3-14ce-42b4-b8ca-f25b9351cf0f" / <img width="1279" height="1450" alt="Screenshot from 2025-10-25 21-14-47"…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-5jpx-9hw9-2fx4
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-5jpx-9hw9-2fx4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-5jpx-9hw9-2fx4 Advisory: NextAuthjs Email misdelivery Vulnerability IDs: GHSA-5jpx-9hw9-2fx4 Record: https://patchnext.com/advisories/ghsa-5jpx-9hw9-2fx4 (revision 3, source checked 26 Oct 2026, 12:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: next-auth 5.0.0-beta.30, 4.24.12. A vendor fix does not mean a deployment is fixed. ## Affected components - npm next-auth: affected < 4.24.12; >= 5.0.0-beta.0, < 5.0.0-beta.30; fixed in 5.0.0-beta.30, 4.24.12 ## Suggested inspection (read-only) - `npm ls next-auth --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on next-auth. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-5jpx-9hw9-2fx4 (OSV record GHSA-5jpx-9hw9-2fx4 lists affected ranges: npm next-auth >=0 =5.0.0-beta.0 <5.0.0-beta.30 (fixed)) - Verified: https://github.com/advisories/GHSA-5jpx-9hw9-2fx4 (GitHub-reviewed advisory GHSA-5jpx-9hw9-2fx4 lists affected ranges: npm next-auth >=0 =5.0.0-beta.0 <5.0.0-beta.30) Commands are suggestions: review each one before running it.
Loading voting…