SAML PHP Toolkit Vulnerability on xmlseclibs CVE-2025-66475
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (onelogin/php-saml 4.3.1, 3.8.1, 2.21.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist onelogin/php-saml
- Affected
- < 2.21.1>= 3.0.0, < 3.8.1>= 4.0.0, < 4.3.1
- Fixed in
- 3.8.1, 4.3.1, 2.21.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5j8p-438x-rgg5 lists affected ranges: Packagist onelogin/php-saml >=0 =3.0.0 =4.0.0 <4.3.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Summary There is a critical vulnerability on xmlseclibs CVE-2025-66475, a dependency of php-saml Update to the following versions of php-saml which forces the use of patched versions of xmlseclibs: - 2.21.1 - 3.8.1 - 4.3.1 Impact Signature Wrapping Vulnerabilities allows an attacker to impersonate a user.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-5j8p-438x-rgg5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-5j8p-438x-rgg5 Advisory: SAML PHP Toolkit Vulnerability on xmlseclibs CVE-2025-66475 IDs: GHSA-5j8p-438x-rgg5 Record: https://patchnext.com/advisories/ghsa-5j8p-438x-rgg5 (revision 1, source checked 26 Oct 2026, 14:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: onelogin/php-saml 4.3.1, 3.8.1, 2.21.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist onelogin/php-saml: affected < 2.21.1; >= 3.0.0, < 3.8.1; >= 4.0.0, < 4.3.1; fixed in 3.8.1, 4.3.1, 2.21.1 ## Suggested inspection (read-only) - Packagist onelogin/php-saml: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on onelogin/php-saml. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-5j8p-438x-rgg5 (GitHub-reviewed advisory GHSA-5j8p-438x-rgg5 lists affected ranges: Packagist onelogin/php-saml >=0 =3.0.0 =4.0.0 <4.3.1) Commands are suggestions: review each one before running it.
Loading voting…