@grackle-ai/server has a Missing Secure Flag on Session Cookie
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@grackle-ai/server 0.70.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- <= 0.70.4
- Fixed in
- 0.70.5
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-5j35-xr4g-vwf4 lists affected ranges: npm @grackle-ai/server >=0 <0.70.5 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5j35-xr4g-vwf4 lists affected ranges: npm @grackle-ai/server >=0 <=0.70.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 2.3 · CVSS:4.0/AV:A/AC:H/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact The session cookie is set with HttpOnly; SameSite=Lax; Path=/ but does not include the Secure flag. This means the cookie will be sent over plain HTTP connections. Since the server binds to 127.0.0.1 by default and uses HTTP (not HTTPS), this is acceptable for localhost use. However, when --allow-network is used to bind to 0.0.0.0, cookies could be transmitted over insecure network connections and intercepted by an attacker. Affected code: - packages/server/src/session.ts:76 — cookie string lacks ; Secure attribute Patches 0.70.5 Fix: Conditionally add ; Secure when served over HTTPS or when --allow-network is enabled: Workarounds Do not use --allow-network over untrusted networks without a TLS-terminating reverse proxy. Resources - OWASP: Secure Cookie Attribute - File: packages/server/src/session.ts
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-5j35-xr4g-vwf4
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-5j35-xr4g-vwf4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-5j35-xr4g-vwf4 Advisory: @grackle-ai/server has a Missing Secure Flag on Session Cookie IDs: GHSA-5j35-xr4g-vwf4 Record: https://patchnext.com/advisories/ghsa-5j35-xr4g-vwf4 (revision 3, source checked 26 Oct 2026, 12:46 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @grackle-ai/server 0.70.5. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @grackle-ai/server: affected <= 0.70.4; fixed in 0.70.5 ## Suggested inspection (read-only) - `npm ls @grackle-ai/server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @grackle-ai/server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-5j35-xr4g-vwf4 (OSV record GHSA-5j35-xr4g-vwf4 lists affected ranges: npm @grackle-ai/server >=0 <0.70.5 (fixed)) - Verified: https://github.com/advisories/GHSA-5j35-xr4g-vwf4 (GitHub-reviewed advisory GHSA-5j35-xr4g-vwf4 lists affected ranges: npm @grackle-ai/server >=0 <=0.70.4) Commands are suggestions: review each one before running it.
Loading voting…