Magento remote code execution (RCE), Cross-Site Scripting (XSS) and other vulnerabilities
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (magento/community-edition 2.2.5, 2.1.14), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist magento/community-edition
- Affected
- >= 2.1, < 2.1.14>= 2.2, < 2.2.5
- Fixed in
- 2.1.14, 2.2.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5gmh-85x8-5cx7 lists affected ranges: Packagist magento/community-edition >=2.1 =2.2 <2.2.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Magento Commerce and Open Source 2.2.5 and 2.1.14 contain multiple security enhancements that help close authenticated Admin user remote code execution (RCE), Cross-Site Scripting (XSS) and other vulnerabilities.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-5gmh-85x8-5cx7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-5gmh-85x8-5cx7 Advisory: Magento remote code execution (RCE), Cross-Site Scripting (XSS) and other vulnerabilities IDs: GHSA-5gmh-85x8-5cx7 Record: https://patchnext.com/advisories/ghsa-5gmh-85x8-5cx7 (revision 1, source checked 26 Oct 2026, 14:24 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: magento/community-edition 2.2.5, 2.1.14. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist magento/community-edition: affected >= 2.1, < 2.1.14; >= 2.2, < 2.2.5; fixed in 2.1.14, 2.2.5 ## Suggested inspection (read-only) - Packagist magento/community-edition: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on magento/community-edition. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-5gmh-85x8-5cx7 (GitHub-reviewed advisory GHSA-5gmh-85x8-5cx7 lists affected ranges: Packagist magento/community-edition >=2.1 =2.2 <2.2.5) Commands are suggestions: review each one before running it.
Loading voting…