mysql Node.JS Module Vulnerable to Remote Memory Exposure
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (mysql 2.14.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm mysql
- Affected
- >= 2.0.0-alpha8, < 2.14.0
- Fixed in
- 2.14.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-5f7m-mmpc-qhh4 lists affected ranges: npm mysql >=2.0.0-alpha8 <2.14.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5f7m-mmpc-qhh4 lists affected ranges: npm mysql >=2.0.0-alpha8 <2.14.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Versions of mysql before 2.14.0 are vulnerable to remove memory exposure. Affected versions of mysql package allocate and send an uninitialized memory over the network when a number is provided as a password. Only mysql running on Node.js versions below 6.0.0 are affected due to a throw added in newer node.js versions. Proof of Concept: Recommendation Update to version 2.14.0 or later.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-5f7m-mmpc-qhh4
- Revision 1 · created ·
Published from osv record GHSA-5f7m-mmpc-qhh4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-5f7m-mmpc-qhh4 Advisory: mysql Node.JS Module Vulnerable to Remote Memory Exposure IDs: GHSA-5f7m-mmpc-qhh4 Record: https://patchnext.com/advisories/ghsa-5f7m-mmpc-qhh4 (revision 2, source checked 26 Oct 2026, 12:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: mysql 2.14.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm mysql: affected >= 2.0.0-alpha8, < 2.14.0; fixed in 2.14.0 ## Suggested inspection (read-only) - `npm ls mysql --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on mysql. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-5f7m-mmpc-qhh4 (OSV record GHSA-5f7m-mmpc-qhh4 lists affected ranges: npm mysql >=2.0.0-alpha8 <2.14.0 (fixed)) - Verified: https://github.com/advisories/GHSA-5f7m-mmpc-qhh4 (GitHub-reviewed advisory GHSA-5f7m-mmpc-qhh4 lists affected ranges: npm mysql >=2.0.0-alpha8 <2.14.0) Commands are suggestions: review each one before running it.
Loading voting…