Skip to content

← Actionable
Medium, CVSS 4.5amended

Winter: Stored XSS through cached Brand Settings and Editor Settings custom styles

GHSA-5cwr-5jxg-pcf6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (winter/wn-backend-module 1.2.14), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.5 · CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:N/I:H/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Impact Users with the backend.managebranding ("Customize the back-end") or backend.manageeditor ("Manage global code editor preferences") permission can provide custom CSS through Settings → Customize Backend → Styles or Settings → Editor Settings → Markup Styles that is compiled through the LESS CSS parser and rendered on every backend page. v1.2.13 addressed CVE-2026-32257 and CVE-2026-32258 by applying striptags() to the compiled output of BrandSetting::renderCss() and EditorSetting::renderCss(). That fix was incomplete. Both methods cache the raw compiler output with Cache::forever() and applied striptags() only to the value returned on a cache miss, so every subsequent cache hit returned the unsanitized value directly into the backend <style element. The first page render after saving therefore appears sanitized while priming an unsafe cache entry, and the stored XSS remains exploitable from the second render onwards. Because the custom styles partial is included by both the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-5cwr-5jxg-pcf6

  2. Revision 1 · created ·

    Published from osv record GHSA-5cwr-5jxg-pcf6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-5cwr-5jxg-pcf6

Advisory: Winter: Stored XSS through cached Brand Settings and Editor Settings custom styles
IDs: GHSA-5cwr-5jxg-pcf6
Record: https://patchnext.com/advisories/ghsa-5cwr-5jxg-pcf6 (revision 2, source checked 26 Oct 2026, 14:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: winter/wn-backend-module 1.2.14. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist winter/wn-backend-module: affected <= 1.2.13; fixed in 1.2.14

## Suggested inspection (read-only)
- Packagist winter/wn-backend-module: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on winter/wn-backend-module.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-5cwr-5jxg-pcf6 (OSV record GHSA-5cwr-5jxg-pcf6 lists affected ranges: Packagist winter/wn-backend-module >=0 <1.2.14 (fixed))
- Verified: https://github.com/advisories/GHSA-5cwr-5jxg-pcf6 (GitHub-reviewed advisory GHSA-5cwr-5jxg-pcf6 lists affected ranges: Packagist winter/wn-backend-module >=0 <=1.2.13)

Commands are suggestions: review each one before running it.

Loading voting…