@asymmetric-effort/specifyjs: GraphQL gql tag allows metacharacter injection
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@asymmetric-effort/specifyjs 0.2.136), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @asymmetric-effort/specifyjs
- Affected
- < 0.2.136
- Fixed in
- 0.2.136
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-5c7w-4wm3-85vw lists affected ranges: npm @asymmetric-effort/specifyjs >=0 <0.2.136 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5c7w-4wm3-85vw lists affected ranges: npm @asymmetric-effort/specifyjs >=0 <0.2.136
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Finding Location: core/src/client/graphql.ts:66-80 The gql template tag function warned about interpolated values containing GraphQL metacharacters ({}():) but still concatenated them into the query string, enabling potential GraphQL injection. Status Fixed in v0.2.136 — The gql function now throws an error when metacharacters are detected in interpolated values, forcing developers to use the variables parameter.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-5c7w-4wm3-85vw
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-5c7w-4wm3-85vw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-5c7w-4wm3-85vw Advisory: @asymmetric-effort/specifyjs: GraphQL gql tag allows metacharacter injection IDs: GHSA-5c7w-4wm3-85vw Record: https://patchnext.com/advisories/ghsa-5c7w-4wm3-85vw (revision 3, source checked 26 Oct 2026, 12:56 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @asymmetric-effort/specifyjs 0.2.136. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @asymmetric-effort/specifyjs: affected < 0.2.136; fixed in 0.2.136 ## Suggested inspection (read-only) - `npm ls @asymmetric-effort/specifyjs --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @asymmetric-effort/specifyjs. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-5c7w-4wm3-85vw (OSV record GHSA-5c7w-4wm3-85vw lists affected ranges: npm @asymmetric-effort/specifyjs >=0 <0.2.136 (fixed)) - Verified: https://github.com/advisories/GHSA-5c7w-4wm3-85vw (GitHub-reviewed advisory GHSA-5c7w-4wm3-85vw lists affected ranges: npm @asymmetric-effort/specifyjs >=0 <0.2.136) Commands are suggestions: review each one before running it.
Loading voting…