Skip to content

← Actionable
Medium, CVSS 5.3amended

Trigger.dev: Unauthenticated Realtime Stream Data Injection via Run FriendlyId

CVE-2026-114086GHSA-59h8-w5q6-mfmp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (trigger.dev 4.5.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
EPSS
  • CVE-2026-114086: 0.38% estimated exploitation activity in the next 30 days; percentile 32.50 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The POST handler for /realtime/v1/streams/:runId/:streamId has no authentication. Any entity that knows or guesses a run friendlyId can inject arbitrary data into its realtime stream. Vulnerability Details File: apps/webapp/app/routes/realtime.v1.streams.$runId.$streamId.ts The action handler (line 17) has no auth wrapper. The code comment says: "Plain action for backwards compatibility with older clients that don't send auth headers." The run lookup at line 29 uses where: { friendlyId: runId } with NO environment scoping (runtimeEnvironmentId is not checked), so production runs are accessible. Run friendlyIds follow predictable patterns (e.g., run1234abcd). Steps to Reproduce Impact Unauthenticated data injection into any run realtime stream. Cross-environment access (no scoping).

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-59h8-w5q6-mfmp

  2. Revision 2 · amended ·

    Amended from osv record GHSA-59h8-w5q6-mfmp

  3. Revision 1 · created ·

    Published from ghsa record GHSA-59h8-w5q6-mfmp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-114086

Advisory: Trigger.dev: Unauthenticated Realtime Stream Data Injection via Run FriendlyId
IDs: CVE-2026-114086, GHSA-59h8-w5q6-mfmp
Record: https://patchnext.com/advisories/ghsa-59h8-w5q6-mfmp (revision 3, source checked 26 Oct 2026, 13:06 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: trigger.dev 4.5.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm trigger.dev: affected <= 4.5.4; fixed in 4.5.5

## Suggested inspection (read-only)
- `npm ls trigger.dev --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on trigger.dev.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-59h8-w5q6-mfmp (GitHub-reviewed advisory GHSA-59h8-w5q6-mfmp lists affected ranges: npm trigger.dev >=0 <=4.5.4)
- Verified: https://osv.dev/vulnerability/GHSA-59h8-w5q6-mfmp (OSV record GHSA-59h8-w5q6-mfmp lists affected ranges: npm trigger.dev >=0 <4.5.5 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…