Skip to content

← Actionable
Medium, CVSS 6.3amended

Sentry SDK Prototype Pollution gadget in JavaScript SDKs

GHSA-593m-55hh-j8gv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@sentry/browser 8.33.0, 7.119.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm @sentry/browser

    Affected
    >= 8.0.0-alpha.1, < 8.33.0< 7.119.1
    Fixed in
    8.33.0, 7.119.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N · score source
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Impact In case a Prototype Pollution vulnerability is present in a user's application or bundled libraries, the Sentry SDK could potentially serve as a gadget to exploit that vulnerability. The exploitability depends on the specific details of the underlying Prototype Pollution issue. [!NOTE] This advisory does not indicate the presence of a Prototype Pollution within the Sentry SDK itself. Users are strongly advised to first address any Prototype Pollution vulnerabilities in their application, as they pose a more critical security risk. Patches The issue was patched in all Sentry JavaScript SDKs starting from the 8.33.0 version. Also, the fix was backported to SDK v7 in 7.119.1. References Prototype Pollution Prototype Pollution gadgets sentry-javascript#13838

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-593m-55hh-j8gv

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-593m-55hh-j8gv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-593m-55hh-j8gv

Advisory: Sentry SDK Prototype Pollution gadget in JavaScript SDKs
IDs: GHSA-593m-55hh-j8gv
Record: https://patchnext.com/advisories/ghsa-593m-55hh-j8gv (revision 3, source checked 26 Oct 2026, 12:31 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @sentry/browser 8.33.0, 7.119.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @sentry/browser: affected >= 8.0.0-alpha.1, < 8.33.0; < 7.119.1; fixed in 8.33.0, 7.119.1

## Suggested inspection (read-only)
- `npm ls @sentry/browser --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @sentry/browser.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-593m-55hh-j8gv (OSV record GHSA-593m-55hh-j8gv lists affected ranges: npm @sentry/browser >=8.0.0-alpha.1 =0 <7.119.1 (fixed))
- Verified: https://github.com/advisories/GHSA-593m-55hh-j8gv (GitHub-reviewed advisory GHSA-593m-55hh-j8gv lists affected ranges: npm @sentry/browser >=8.0.0-alpha.1 =0 <7.119.1)

Commands are suggestions: review each one before running it.

Loading voting…