Skip to content

← Actionable
Low, CVSS 2.0

mnl has segmentation fault and invalid memory read in mnl::cb_run

GHSA-585q-cm62-757j

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mnl 0.3.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io mnl

    Affected
    <= 0.3.0
    Fixed in
    0.3.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
2.0 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P · score source
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

The function mnl::cbrun is marked as safe but exhibits unsound behavior when processing malformed Netlink message buffers. Passing a crafted byte slice to mnl::cbrun can trigger memory violations. The function does not sufficiently validate the input buffer structure before processing, leading to out-of-bounds reads. This vulnerability allows an attacker to cause a Denial of Service (segmentation fault) or potentially read unmapped memory by providing a malformed Netlink message.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-585q-cm62-757j

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-585q-cm62-757j

Advisory: mnl has segmentation fault and invalid memory read in `mnl::cb_run`
IDs: GHSA-585q-cm62-757j
Record: https://patchnext.com/advisories/ghsa-585q-cm62-757j (revision 1, source checked 26 Oct 2026, 15:39 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mnl 0.3.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io mnl: affected <= 0.3.0; fixed in 0.3.1

## Suggested inspection (read-only)
- crates.io mnl: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mnl.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-585q-cm62-757j (GitHub-reviewed advisory GHSA-585q-cm62-757j lists affected ranges: crates.io mnl >=0 <=0.3.0)

Commands are suggestions: review each one before running it.

Loading voting…