Skip to content

← Actionable
Unrated

XSS vulnerability when listing users on add & modify server pages.

GHSA-5822-pw57-vv37

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pterodactyl/panel 1.0.0-rc.7, 0.7.19), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist pterodactyl/panel

    Affected
    < 0.7.19>= 1.0.0-rc.0, <= 1.0.0-rc.6
    Fixed in
    1.0.0-rc.7, 0.7.19

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Impact An XSS vulnerability exists in versions of Pterodactyl Panel before 0.7.19. Affected versions do not properly sanitize account names before rendering them to the dropdown selector in the admin area when creating or modifying a server. Patches This XSS has been addressed in 0.7.19 and will be rolled forwards into the 1.0-rc.7 release. Workarounds No workaround exists without manual patching. See https://github.com/pterodactyl/panel/pull/2441/files for the files changed. For more information If you have any questions or comments about this advisory please reach out on Discord, or by emailing dane at pterodactyl dot io. Thank you to Sergej for the responsible disclosure of this issue.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-5822-pw57-vv37

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-5822-pw57-vv37

Advisory: XSS vulnerability when listing users on add & modify server pages.
IDs: GHSA-5822-pw57-vv37
Record: https://patchnext.com/advisories/ghsa-5822-pw57-vv37 (revision 1, source checked 26 Oct 2026, 13:56 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pterodactyl/panel 1.0.0-rc.7, 0.7.19. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist pterodactyl/panel: affected < 0.7.19; >= 1.0.0-rc.0, <= 1.0.0-rc.6; fixed in 1.0.0-rc.7, 0.7.19

## Suggested inspection (read-only)
- Packagist pterodactyl/panel: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pterodactyl/panel.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-5822-pw57-vv37 (GitHub-reviewed advisory GHSA-5822-pw57-vv37 lists affected ranges: Packagist pterodactyl/panel >=0 =1.0.0-rc.0 <=1.0.0-rc.6)

Commands are suggestions: review each one before running it.

Loading voting…