Wallabag user can disable 2FA unintentionally
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (wallabag/wallabag 2.6.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist wallabag/wallabag
- Affected
- >= 2.0.0-alpha.1, < 2.6.7
- Fixed in
- 2.6.7
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-56fm-hfp3-x3w3 lists affected ranges: Packagist wallabag/wallabag >=2.0.0-alpha.1 <2.6.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact wallabag was discovered to contain a Cross-Site Request Forgery (CSRF) which allows attackers to arbitrarily disable 2FA through /config/otp/app/disable and /config/otp/email/disable. This vulnerability has a CVSSv3.1 score of 4.3. You should upgrade your instance to version 2.6.7 or higher. Resolution These endpoints now require POST method. Credits We would like to thank @dhina016 for reporting this issue through huntr.dev. Reference: https://huntr.dev/bounties/4c446fe7-2a44-4907-b0cf-4ab77d75c487/
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-56fm-hfp3-x3w3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-56fm-hfp3-x3w3 Advisory: Wallabag user can disable 2FA unintentionally IDs: GHSA-56fm-hfp3-x3w3 Record: https://patchnext.com/advisories/ghsa-56fm-hfp3-x3w3 (revision 1, source checked 26 Oct 2026, 14:09 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: wallabag/wallabag 2.6.7. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist wallabag/wallabag: affected >= 2.0.0-alpha.1, < 2.6.7; fixed in 2.6.7 ## Suggested inspection (read-only) - Packagist wallabag/wallabag: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on wallabag/wallabag. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-56fm-hfp3-x3w3 (GitHub-reviewed advisory GHSA-56fm-hfp3-x3w3 lists affected ranges: Packagist wallabag/wallabag >=2.0.0-alpha.1 <2.6.7) Commands are suggestions: review each one before running it.
Loading voting…